Motors are not moving (randomly)

Hi,

we have a strange problem which we could not diagnose properly.

  • We tested all our motors and Victor drivers one by one. They were all running.
  • We created a simple program which only creates PWM outputs. I checked all ports with a multimeter, and they are fine too.
  • I double checked that there is 12V power on the left side of Victors, and their yellow LEDs are flashing.

However, when we connect the PWM outputs to 2 Victors, only one of the motors turns. After formatting CRIO and downloading the program again a few times, that motor stops still and the other one turns. :ahh: The LED of the moving Victor is constantly on, while the non-moving is still flashing. Swapping the PWM ports does not change the moving motor.

Yeah, I know it’s strange but I thought there are many experienced people here and someone could suggest a solution. :confused:

thanks…

Are you sure this is not a software problem?

Are you guys using Java?

We are using Labview.

I don’t think it’s a software problem, because correct PWM is generated on both output pins of the sidecar. The motor continues turning after swapping their PWM ports on the sidecar.

How did you swap the PWM Cables on your DIO?

Have you tried swapping the PWMs on the Viktors?

See if the other Viktor keeps running after the PWMs are swapped

We swapped the ports PWM cables are connected on the sidecar. Also, we tried changing the PWM cables.

One Viktor keeps running and while the other is still.

So let me get this clear

Victor A = Does not run
Victor B = Runs, does not stop

Swap PWM Cable from Victor a to Victor B and vice cersa

Victor A = Runs, does not stop
Victor B = Does not run

no, that would be much easier. It’s like:

Victor A = Runs
Victor B = Does not run

Swap PWM Cable from Victor A to Victor B and vice versa

Victor A = Runs
Victor B = Does not run

Reboot CRIO a few times,

Victor A = Does not run
Victor B = Runs

Swap PWM Cable from Victor A to Victor B and vice cersa

Victor A = Does not run
Victor B = Runs

Verify that the LEDs on the digital breakout board are on. My guess is that they are dim or out and that the 12V power to the breakout is missing.

You should also make sure that the ribbon cable from cRIO to breakout board is well seated.

Greg McKaskle

At this point, I don’t think its a software nor a Viktor problem

I would try replacing your PWM Cables and your ribbon cable from the Crio to the DIO.

Try finding any problems with electronics

thanks for the replies. it was revealed that the problem was caused by the battery. all the software and electronics were correct. a new and charged battery solved the problem.

We had that problem last night. Funny how sometimes all you need to do is plug it in (to a charged battery). :stuck_out_tongue:

That’s what I would have suggested first…low batteries cause all kinds of weird problems.

Glad you figured it out.

I hope our discussion here saved you from losing a few days like us :slight_smile:

We had a similar problem when we first fired up our robot for the first time

Turns out it was a wiring problem, resulting from a boggling design flaw with the Victor.

The PWM cable is actually capable of (easily!) plugging into the slot, with all of the pins completely missing the terminals inside, but without bending any cable pins, or looking any different from the outside.

I will admit it was me who plugged in the wrong ones, but the difference in the “feel” and look of plugging them in wrong was identical to plugging them in right.

our problem was different than yours. the cables were good and they were well connected. the battery was not able to supply enough current. probably, due to the design of Victors, one was drawing all the current the battery could supply, and the other Victor was not getting any current at all.