MPLAB error(large pic)

This is perhaps the most humourous error message ever.

I have my code stored on a Network Bridged hard drive (in my notebook connected at 600mbps). When i open MPLAB on my Desktop, and go to File–>Open Recent Workspaces–>FRCCODE(my workspace name), i get the following error. note, when i use the standard open menu, it works perfectly. I thought the message was humorous though, so i figured id share.

ETA, sorry about the size, my screen is 1280x1024

gee, and I thought that was a bad thing… :rolleyes: :stuck_out_tongue:

It was kind of weird, i mean, how bad is an error if they dont even know what to call it?!


Actually, it is more common than you realize. Especially when a large group of programmers are working on a project, the exception handler must be written to respond to “unknown” events without, itself, causing an exception.

In mature products, these unknown evens are rare. But because this mplab is a scaled down version made specifically for FIRST, I’m not surprised that an undefined event has reared it’s ugly head.

Realize that there are 1000 teams with 2 to 10 “newbie” programmers out there banging on this system. I’m surprised that this has not happened to someone else already…


Really, i do understand, i just thought it was a funny error. Errors like this are caused by inefficent and inattentive programmers. I mean nothing against the mplab programmers, and i am thankful for them doing this for first.

I have been on many application programming teams,and many are the kind of projects that dont allow errors like this. Errors like this arise when a certian programmer does not do their job properly. This is the reason things like Windows ME occur.

It is almost always due to hiring programmers that are not highest quality, for less money. This is really my main problem with outsourcing overseas.

Anyway, if everyone did their job as best as is possible, things like this would not happen. I understand that MPLAB would like to make money, so i have no problems with this.

Oddly enough, i just thought this was one of those error messages that struck me as funny, along with the ones that repeat the message 3 times, and the ones that tell you that no error has occured.

hey, any error message that doesn’t result in a crash is better than those i’ve been getting sometimes (win32 illegal operation errors). at least it’s failing gracefully.

It is a shame that a company with such poor performance can be the leader in OS design. I find it almost blastphamous that Windows XP is really just what MS promised us in 1994. I wish that at least once a company would give out everything they promise. MPLAB is fairly well written, and with the exception of a few minor errors, and the usage of a few poorly written routines, has worked nicely.

Gee! Thats like saying “Sorry, the nationals does not exist.” Well, thats just one small error afterall :smiley:

I realize mplab is somewhat buggy for those who do not run XP, but many of these errors are the fault of Microsoft. Most major companies will write their own routines to do these things, usu. more efficently, and less buggy. I have had very few problems with they system.

My oddest problem was with IFI Loader (the original verison,havent tried since). I would upload my program to the bot, and while it was running (with the output box), i would close the output box. The computer would then graciously give me a BSOD (XP No less!), and then shut down. It took me about 20 minutes to figure out why. Again, something programmed so quickly, yet they looked over something so simple. Its a shame really.

Hey! Windows ME ain’t actually all that bad (except that IFI loader won’t install. I worked around that anyway) And XP won’t let you even delete “Thumbs.db”. Basically: the simplicity and ‘dumbness’ (won’t use the computer for you :rolleyes: ) of 98 well being clean up and updated (USB keys, for instance). Of course, 2000 wouldn’t be bad.

Are you kidding? ME is an abortion!
XP does let you delete Thumbs.db, but only if you have all the idiot proofing turned off. 98 is fairly retarded, and is still one of the worst MS has produced. In my opinion, for anything but high end gaming, 2000 is the way to go, for games, get XP with the idiot proofing off.

Of course, running Windows 2003 Server 64bit edition is as good as it gets for windows! I would still love to see Linux take over, but it will forever be a minority.

600Mbps? What kind of network r u using?

I have actually had this error too(don’t remember what circumstances). Ur not alone.

I am actually connected via 1 1394 cable, and 2 10/100 nic cable. I network bridged the 3 cables to get maximum connection speed. So when it works correctly, i get 600mpbs, though i may have a combo of them sometimes (100,200,400,500, or 600).

We got this exact same message. We tried to open a workspace that no longer existed in that location. Are you sure that the workspace you are trying to open has not moved? I know that windows may have assigned you network drive a different letter, it will do this is it’s original was taken by something else. (This has happened to me a few times, I guess that’s what you get when trying to plug in an external hard drive, card reader and flash drive at the same time. My flash drive is now assigned to L: whereas it was G: before.)

–Damian Manda

Nope, it is the exact same directory, still available and everything. I believe that it is just being retarded. It seems to happen every tiime the network bridge shuts down and comes back on (ie, if the drive has become unavaliable since the last time i used it). Its more of a nucince than anything.