My cRIO is not properly imaging

My team has been trying to continute programming even after build season is over, and we are trying to set up a cRIO. We have a cRIO 1 with 8 module slots. I’m using the FRC 2014 cRIO Imaging Tool But, when I use the imaging tool the dip switches don’t appear to register on the tool. All of them appear off, despite attempts to switch them on and off. Another thing, the modules do not appear in the cRIO on the right of the tool.

These are just cosmetic, so I tried to image the cRIO anyway. When I try it comes up with an error that tells me that it cannot reset the IP and that I need the IP reset Dip switch turned off. I’ve tried changing it on and off and there is no change.

I’ve made sure to follow the cRIO Imaging Guide and followed the troubleshooting included there. I’ve also searched for forums and have found no problem similar to mine.

I hope I can get some pointers on what to try after this.

It sounds like your computer is not on the same subnet as the cRIO. Look at the IP of the cRIO when it is detected by the tool and make sure your computer is set to a static IP with the same first 3 octets (likely 10.TE.AM where TEAM is your 4 digit team number or 169.254.XX if the cRIO has gotten set to DHCP).

The switch and module information won’t show up until a recent image has been successfully loaded onto the cRIO. Don’t worry about it (yet).

After you changed the position of the IP Reset switch, did you reboot the cRIO?

All of the switches (with the possible exception of CONSOLE OUT) should be in the OFF position. That means the side of the switch adjacent to the word “OFF” should be depressed, and the side of the switch adjacent to the label should be up.

Try to reset the cRIO’s IP using NI Max. I don’t have a cRIO on hand at this moment (I’m at home) so it should be somewhere in NI Max. I’ve had the same issue before.

We were having problems earlier in the year trying to get our cRIO to re-image.

We had to toggle the Safe Mode dip switch - I don’t remember if it had to be on or off to get the tool to image it.


I got it working, thanks for the replies. I reset the cRIOs IP with the NI MAX program and then I flipped all the dip switches in the off position. I also had to run the imaging tool twice - once to format it and another to image it.

I’ve found that sometimes the imaging tool will just refuse to work with a computer no matter what you try. This has happened with one of my laptops in the middle of a build season. If you can try switching computers (making sure the IP and everything else are set right). Hope this helps!