NASA Grant Application Error message

Tryin to complete the grant application and keep getting the error message "frc-grants.arc.nasa.gov says Please complete all of the highlighted questions(s).
All of the questions are answered and nothing is highlighted. Anyone have a suggestion or contact person.

Thanks

1 Like

That link it’s sending is opening up the 2021-2022 grant application vs the 2022-2023 one, don’t know if it’s a NASA side issue or you may just have the wrong year…?

The application shows it is the 2023 Rookie Grant application.

…hmm odd. Sorry to say but I am out of options : /

I have been successful submitting the application through this link: Robotics Alliance Project FIRST Robotics Competition Grants Portal

That is the link we are using.

We had the same issue before and had to log out and clear browsing data then log back in and everything worked fine. Not sure if that is what you are facing, but it worked for us.

Seemed to be a situation where our application was open too long and timed out, but didn’t want to work right by just signing in again.

Your suggestion fixed it. Thanks for help.