Nav-x not working

Our team’s navx doesn’t seem to work at all. I am not able to update the firmware on it. I followed all of the given instructions. When I do it, I get this error:

Inside the details box:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.DllNotFoundException: Unable to load DLL ‘STDFUFiles.DLL’: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail. (Exception from HRESULT: 0x800736B1)
at NetDFULib.HEX2DFU.STDFUFILES_CreateNewDFUFile(String szDevicePath, IntPtr& handle, UInt16 Vid, UInt16 Pid, UInt16 Bcd)
at NetDFULib.HEX2DFU.ConvertHexToDFU(String hex_file_name, String dfu_output_name, UInt16 Vid, UInt16 Pid, UInt16 Bcd) in c:\Users\Scott\Documents\GitHub
avxmxp\c#\NetDFULib\HEX2DFU.cs:line 27
at navXFirmwareUpdater.Form1.button1_Click(Object sender, EventArgs e) in c:\Users\Scott\Documents\GitHub
avXFirmwareUpdater\Form1.cs:line 569
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
Assembly Version:
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/Kauai%20Labs/navX-MXP/navXFirmwareUpdater/navXFirmwareUpdater.exe

Assembly Version:
Win32 Version: 4.0.30319.34250 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

Assembly Version:
Win32 Version: 4.0.30319.34262 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

Assembly Version:
Win32 Version: 4.0.30319.34239 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/Kauai%20Labs/navX-MXP/navXFirmwareUpdater/NetFULib.DLL

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/Kauai%20Labs/navX-MXP/navXFirmwareUpdater/navXComUtilities.DLL

Assembly Version:
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

Assembly Version:
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Management/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Management.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

< jitDebugging=“true” />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

I tried looking the error up on google, and I only got one thing and it was non-FRC related.

I found STDFUFiles.DLL and put it in Windows\System32 and tried to register it with regsvr32, but it instead said that it “couldn’t find STDFUFiles.DLL”.

I tried it on Windows 10 and 8. Neither of them worked and they gave me the same error.

Is there anything I’m missing here?


From your description (the details are very helpful) it appears that one of the device drivers that are installed when you run the NavX-MXP setup.exe program did not successfully install.

This can occur if the user you are logged in as when you install the software does not have sufficient privileges to install a device driver. Please ensure you have run the setup.exe as administrator, which should allow the signed driver (which allows firmware to be installed to the NavX-MXP) to be installed correctly.

I just ran into what appears to be the exact same problem, and for me the fix was to install Visual C++ 2005, which is available here:

I know people hate necroing threads, but I just want to say that installing Visual C++ 2005 worked for me.

Thanks Ben!