NavX Library causes Gradle error

We are following the instructions on the NavX website, but our code won’t build.

We have installed the newest WPILib and VSCode, and we have installed the newest NavX software. We create a new project, “Manage vendor libraries”, “Install new libraries (online)” [or offline, we’ve tried both; our coding computer is connected to the Internet]. Then when we try to deploy or build, we get the following terminal output:

Executing task: gradlew build“C:\Users\Public\wpilib\2021\jdk” <
FAILURE: Build failed with an exception.

Any advice would be appreciated. Thank you!

That URL works for me. Is there a firewall blocking the download?

It really shouldn’t be trying to pull that file at all, it’s just that the NavX modules file for some reason wants to have it. The 2021 version of it is installed locally by the WPILib installer.

These links return 404 errors when opened in the browser for me. Is there another way to download these?

I somehow fixed it…
I created a new project and installed everything offline, it didnt work.
Then I uninstalled and installed again, and it worked.
Only god knows what happened

The quoting is weird on CD, the link I quoted for some reason includes the trailing '. should not 404.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.