NavX-micro not connecting to Windows PC

We are experimenting with the navX this year and would like to try and use the fused heading. If I understood correctly, this requires the magnetometer to be calibrated. I installed the latest build of the navX software on my Windows PC, but when I tried to connect the navX by USB, navXUI would not detect anything and Device Manager says that the driver for the STM32 Virtual COM Port could not be found. If anyone has experienced something similar or has a solution, we would really appreciate it. Thanks!

Here’s a link to the latest USB Serial driver installers.

This is installer version 1.5.0, newer than the one currently installed w/the navX-MXP setup.

Choose the 32 vs 64 bit version to match the 32/64-bitness of your Windows OS. Then run the Windows 8 installer (this should be run as administrator on your computer) This should install updated .inf files so that the vendor and product id of the navX sensor indicates that the Windows 10 usbser.sys driver should be used.

Please let me know your findings; we see different behavior on different Windows 10 computers, so we are trying to get as much info as we can.


  • scott

Thanks! As I do not have the sensor with me at the moment, I will test it on Monday when I get the sensor again. I’ll let you know how it goes.

I would highly recommend using a NavX-MXP instead of a micro. The micro is widely-known to break easily and not function properly. I had the problem 2 years ago, switched to using mxp’s and never went back. The NavX-MXP is so much more reliable. Worth the upgrade, trust me as a third year programmer with three years of use with mxp.

Thanks. I’ll consider getting one from FC in the 2020 season. During my 1.5 years of FRC programming, there was virtually no one teaching me what to do. I didn’t know how to use the navX until this year. :sweat_smile: I do like how the mxp just plugs in, instead of having to use this awkward cable for both I2C and 5V power. By “not function properly”, are you referring to during development or in matches? Should I be concerned and try to implement some sort of a fail-safe?

Please review the Best Practices documentation. Smart sensors like navX-Micro and navX-MXP contain delicate circuitry. An enclosure is recommended for navX-Micro to protect it from physical and electrical damage.

Additionally, the RoboRIO support for USB Serial ports has classically had some issues, especially when used simultaneously with USB Web cameras. So when used in FRC, it’s recommended to use the navX-Micro I2C interface. More info on the communication options can be found here.

navX-MXP plugs directly into the RoboRIO, and provides both I2C and SPI interfaces which are very fast and reliable, so it avoids these issues.

navX-Micro is a fine sensor (in fact, it contains the identical circuitry and firmware that’s also on navX-MXP) and it’s used in several robotics competitions worldwide. Teams that use the navX-Micro I2C interface and protect the sensor with an enclosure use navX-Micro successfully in FRC. Let me know if there are any questions or concerns on that.

The drivers worked. Thanks!

Great to hear it. Hope all goes well for you and your team; feel free to reach out if you have any further troubles.


  • scott

I was also able to use the 1.5.0 version succesfully on my windows 10 laptop, whereas the bundled version didn’t work.

Thanks, Joe. We haven’t figured out the secret sauce yet to get 1.5.0 integrated for automated installation, but it appears that’s needed now on the latest Win10 releases.