NavX-MXP Board User Interface


#1

This is my teams first year trying to use the NavX board on our robot. We bought the board and ran the setup to get all of the different interfaces, but when trying to load the UI to see the Rotation, and all that other stuff a black screen shows up saying no com’s in red. I have contacted Kuwai Labs and they said run the setup.exe file as a administrator to download the drivers for the board. When I did this still the same problem. Any help would be appreciated, thanks in advance!


#2

Try unblocking the zip file per

Then connect the navx micro usb port before you open up any navx programs and watch for the driver loading.


#3

It sounds like you are not connecting the navX to your computer via a serial port. If you have, then my next guess is that you are telling the navX to use a different port than the one your computer has. Look in the list of ports in the device manager (in the control panel) for the correct COM port to tell the navX.


#4

I am unable to even get to the Com tab to change. I have tried running as admin, and i have made sure Windows 10 wasn’t trying to protect me from harmful things. Also, i never see the driver loading. When i go into Manage Devices it always says it needs drivers.


#5

I have the same issue. I have Java JDK 11 and JRE 8 installed and have reinstalled & ran with admin privileges.


#6

Have you tried a second pc / cable? Are you connecting the navx before you open navxui? We found we had to do that before the driver would load


#7

Yes we have tried another computer and it works. But we neef a differnet one because that one won’t be there as it is a mentors. And we try load the UI after it gets connected but still the same issues. We are just trying to figure out why it is being so choppy for us, where it works on one but not the other using the same install steps and everything.