Navx not working

Our teams navx is not working its not uptading any values in code and i printed to things isConnected() and isCalibrating() and i found that isConnected() always give false while isCalibrating()
is true. We searched it but we can’t found anything so What is problem in roborio or How can we close calibrating mode from navx ?


Are you calling the calibrate method during your program? If so, make sure you are only calling it one time outside of a periodic or execute loop, preferably on the robotInit method.

we call reset method in command but in initialize not in execute or periodic we didn’t call any calibrate method so far should we or not ?

1 Like

Can you share your code?

Here are a few things to check:

  • Make sure the NavX is getting power. Does it light up?
  • Make sure you’re using the 2023 vendor library.
  • Check that you’re passing the correct SPI port to the constructor.
  • Our navx light doesn’t light up
  • Our libraries are 2023 vendor library (all of them)
  • We connected navx through mxp port

I will share our code from github near 1 or 1.5 hour

1 Like

Here is our code:

1 Like

I strongly suspect that the issue is the way you’re initializing the AHRS object; specifically, you aren’t passing the SPI port into the AHRS (NavX) constructor like @gdefender suggested.

In your file, on line 14, you initialize the NavX as follows

AHRS navx = new AHRS();

According to the example code provided by Kauai Labs, it needs to be

AHRS navx = new AHRS(SerialPort.Port.kMXP, SerialDataType.kProcessedData, (byte)50);

Give this a try and let us know if it solves your problem.

The first line will initialize the navx with the default interface (MXP SPI). I don’t recommend changing it unless you have a good reason (something else using the spi port or navx not on the MXP).

My bad. The provided sample code needs to be updated then.

We wrote the navx with you said that way but it’s not worked too

We don’t see any uptades on these smartdashboard values and it always calibrating not connecting

And we have only calibrate method in robotinit part in

In addition we have no leds lighting up in navx and it always become hot when we connect navx

Extra: we tried to type of calling navx

AHRS navx = new AHRS();
This didn’t work

AHRS navx = new AHRS(SerialPort.Port.kMXP, SerialDataType.kProcessedData, (byte)50);
This didn’t work too

1 Like

Can you try
private final AHRS navx = new AHRS(SPI.Port.kMXP);

Edit: and one more thing to check, does the led’s turn on when you connect it to your pc via mini usb? Do you get any values from Navxui? And have you updated the firmware to the latest version?

@Yigit is right. Assuming you are using the NavX-MXP. Make sure the LEDs are lit up and you are using the latest firmware.

See this subsystem using it.

SwerveTest/ at main · FRCTeam5484/SwerveTest (

Agreed. I would check firmware first. Normally any Navx firmware issues we’ve had are solved by a firmware update. The fact that its not lighting up worries me. By any chance do you have another nav X you could try if updating the firmware doesn’t work?

private final AHRS navx = new AHRS(SPI.Port.kMXP);

that also didn’t work.

also navx leds doesnt turn on while its on roborio or connected from pc by mini usb cable and we cant see navx from the apps of navx

and we have only one navx

1 Like

Its dead Jim. If the LEDs aren’t lighting up even when plugged in via USB, its dead.

Take a close look at the pins. We had one that got knocked around and the pins were shorted. We straightened them out and it worked, but we decided it wasn’t competition worthy any more.

I have two questions:

  1. The lights are doesn’t turn on but it’s heating is navx still working or not?

  2. Can we detect short circuit from naked eye or do we need to use tools like microscope, multimeter or etc. ?

1 Like

Heating is a sign of a short. Is the board scratched or are the pins on top bent?

We couldn’t found any scratch or bent on pins we took some image:

Flashed photo from top

Normal photo from top

Another photo from top

Photo from back

Flashed from back

We have this pin that connected to 3.3V should we change to 5V or remove it completely and I think we putted 5V and it didnt worked too

Inside of this pin

1 Like

I don’t see any obvious physical damage, so it’s probably dead.
The jumper is for devices you connect to the NavX, so it shouldn’t matter.