Need help installing WindRiver

Over the past few days I have been trying to install Windriver on our E09 Classmate. It has been reimaged properly and I am using an external disk drive in order to run the CD. I am able to install the first component, but it always gives an error at the compiler. I have attempted multiple restarts and reinstalls but thus far no effort has been successful. The error message reads as follows:

“The installer engine was terminated by an unknown error. This can occur if multiple installs were run in parallel, a user sends a kill signal, or there is an operating system problem. A system reboot will usually solve the problem. Afterwards restart the installer to install your products.”

I also took a screenshot just in case it’ll help. I’ve honestly exhausted my ideas on how to fix it. Please help!

Check the remaining disk space – windriver is pretty big.
After installing windows, you usually have just enough space to install the driver station.

Id recommend installing it on another computer other than the classmate since the classmate is not all that great.

The remaining disk space leaves well over 300mb after installation, so I don’t believe that’s the problem.

We have a small laptop that we might be able to install it on, but I heard that Windows 7 is needed for functionality with the Kinect’s SDK, and it currently runs XP. Would we have to buy a copy of Windows 7 for the computer in that case? Other than that, i don’t believe we currently have access to another computer that’s any bit better than the classmate.

Thanks for the advice both of you. I’ll look into the space requirements again. Any other solutions would be appreciated!

I’m going to take a stab and say you are OUT of disk space DURING the installation. If you show 300MB free “after” (when after is unsuccessful), then it likely failed during and wound up leaving you with 300MB afterwards. If you can make room, this may work just fine but it does sound sneakily like out of disk space.


My laptop’s installation ended up taking about 2.01 GB, so 300 MB is NOT going to cover it. The last 3 programs it installs alone were over your 300MB, and the screenshot you have says it failed on the very first program.

On not having enough disk space, I spent a bit of time clearing out HD space till we had approx 3300 MB of free space. I attached another image of the same error to prove that after the first installation (While the first image appeared to have errored during the first install, it had already actually installed the previous one in a previous install, so it started up at the second one.) I have attempted to reinstall it without removing old files (the first time I attempted to reinstall), and reinstalling fresh as well numerous times.

@Dusk Star
I thought it was strange that the install took 2.01 GB as the installer shows less, but as the image shows in the “Disk Space Information” it looks as if it would be fine. Also, nice icon :stuck_out_tongue:

That being said, thank you for the advice thus far, and my team is looking into buying a new laptop. I am relatively sick of using this laptop for programming and such, haha.

Edit: Just tried installing it on another laptop (not exactly new, I think it actually manages to be slower than the classmate). It’s a Windows XP laptop with an 80GB HD. I got the same exact error. We’re looking to purchase another laptop, although I am starting to suspect it might perchance be the CD or the disk drive (it’s an external DVD Writer/Reader that has served me faithfully for many years, but I’m not sure if it may have broken down - although it did install the first bit so I don’t know :/). What are my options if the disk is the problem? I’m going to try and install it on my desktop at home tonight as well, just to check if it’s related to the external disk drive or CD.

Not quite the same error! this one finished the first program before crashing, at least!

And I do not find it odd at all that windriver takes up 2.01 GB, as the .iso files (We have 4 programmers, and so it is faster to rip the disk and install from a virtual cd drive than to wait for each person) are 1,648,00 KB and 1,900,000 KB, respectively. So it actually installed to a smaller area than it took up on disk!

The 2.01 GB size is from the size of my windriver folder. The FRC updates probably didn’t take up a whole gig, so the install size is likely larger than the disk says. (or it might be the FRC libraries from NI, that you install using the Labview flash drive)

And thanks for the recognition of the profile pic :smiley:

@Dusk Star:
Unfortunately, I’m actually no farther along. If you look at the first installation, it’s installing the “Wind River Compiler 5.4.0”. If you look at what it failed at in the other one, it’s also “Wind River Compiler 5.4.0”. I had installed Wind River Workbench 3.0 previous to taking the initial screenshot, but had cleared everything out for a fresh install for the second one. Thanks for the information, though!

Edit: Okay, this is striking me as very strange. I brought home the CD to install on my desktop, which is a 64-bit Windows 7 intel i7. Strangely enough, I couldn’t get very far in the install without it freezing when the CD was in the built in Optiarc DVD RW AD-7230S (or so it says in Device Manager). Notably I couldn’t get past the licensing part when it would suddenly stop responding, giving me quite a hassle as it would not respond to being shut down by the Task Manager or end processing. I later realized that removing the disc from the drive, causing a “There is no disk in drive D” error message and clicking cancel could end that a lot quicker.

However, the interesting thing is I decided to give it a shot and plug in my external disk drive, the same one I mentioned earlier. I tried installing it through that. I had no freezing or locking up in a “not responding” sequence. I did, however, get past the first install and fail at the second, just like I had with both other laptops. I unfortunately don’t have any other disk drives to try currently, but why would my computer’s built in DVD drive cause freezing while the external disk drive causes the compiler to be unable to be installed?

For notes, as I thought it might be an operating system issue, my Desktop is a 64 bit Windows 7, the Classmate we have is a 32-bit Windows 7, and the other laptop I had tried to install it on was a 32-bit Windows XP. Tomorrow I do plan to buy a laptop for my team, as we really could use a faster and higher resolution laptop for our electronics team. Hopefully, if the laptop we get has a disk drive, that one will work. For now, I’ve gotten myself more confused. Does anyone have any thoughts a to what might cause this?

I would suspect the disc, or the optical drive[s] (or possibly a combination of the two). I assume you’ve checked the disk for visible defects (cracks, scratches, etc)

If the disk is semi-broken and/or your drive isn’t as ‘sharp’ as it used to be it’s possible that it can work ok for a while before crashing and burning.

One thing you could do to test this is to try copying the contents of the disk onto the hard-drive (rather than installing). You won’t be able to use windriver obviously, but you can test how the drive performs under heavy use. If the file transfer crashes out too, you know you’ve got a problem. If it does work, get a decent size thumb drive, rip an iso of the cd onto the thumb drive (I don’t know what programs are good for this anymore) and use a iso mounting tool (like daemon tools) to try installing it from the iso.

You don’t even need to move it to a thumb drive, Daemon tools will let you mount an iso file as if it were burned to disk. And you can use it to make an iso from the windriver disks to begin with.

The thumbdrive would be to make sure you don’t run the HDD out of disk space, unless I’m misunderstanding you.

I was assuming that his laptop (not the classmate) would have enough free space to hold the 4gb worth of .iso files. If you don’t have the space, using a flash drive is probably the best idea though.


Yeah, I recently looked at the disk again a bit more meticulously and it looks like there are actually scuffs/bubble-looking things in a small part of the disk. I’m guessing the disk was manufactured faulty which lead to certain parts being unable to be read. I have made a copy of the disk on the desktop, and through that process I’ve discovered the exact files that don’t work. In the D:\images\CDR-R113198.1-1-00 and D:\images\CDR-R113200.1-1-00 folders on the CD, the output file is unable to be accessed normally. So, it must have just been a disk error. I believe Dusk Star might be able to load those files so I can have them by tonight, but if not I’m headed to a nearby school to use their disk.

I’ll edit this again to confirm that that fixed the problem afterwards. Also, so people understand we -did- get a better laptop for my robotics team, I picked up this one yesterday:
Ironically thanks to this we’ve finally been able to move past our awfully slow netbook and the classmate, so I guess this was a blessing in disguise. Sigh* if only I didn’t have to be a senior now and could stay around to use this baby ._. Thanks again for everyone’s help!

Edit: I got access to a CD from team 100 and it works! Thanks for everyone’s help.