Need help recovering corrupt .3dS files and backups.

OK this is just about any animators worst case scenario
it’s 6 days before the animation is due, and we are just about to start the rendering (yeah not a lot of breathing space), I just made my final touches on one of the models when I saved it, and 3ds MAX, surprisingly (not) said it’s gonna crash, and asked if it should backup my file, now considering the fact I saved I hesitated but I said yes anyways
well after it crashed and I started it over I tried opening the file
didn’t work, same with the recovery file (Said it can’t open it)

well luckily I had a back up file I opened that one, made my changes and saved as a new file, then 3ds max8 did the same problem, and BOTH the backup file and the newly saved ones don’t work AND none of their recoveries

I have no more backups, meaning an ENTIRE model is GONE, well I have some early starts, but not much,

what can I do to fix the .MAX files? is this a known problem?
I’m really stressed out because of this

if your wondering what action I did was, “scale uniform” down a bit then re-align that object (it was a robot claw, teaser =)
then save, then it crashed

now I tried making a new file (just a cube) and when I saved it, it worked
so I’m kinda…I dunno what to do

please help THANKS!

I’ll check this forum frequently but in any case:
my MAIL and MSN: Nimmysonny@yahoo.co.uk
ICQ:96992374
AIM:NimrodHaShikor

please help me guys, this could destroy our animation and I promise to give you credit where credits due.

cheers!

i know of nothing to do to save a corrupt model. sorry
exactly how complicated is this model? can you redo it?
if you want, post a pic of what you want and people can offer tips on how to make one quickly.

I’ve encountered this before too, and unfortunately, just had to go back to the last ‘checkpoint’ save that I had.

There is a bug in MAX where upon crashing, and attempting to save at crashtime (save a copy), that not only the file that you were working on becomes empty, but the recovery file also gets written as empty. Check and make sure the file sizes aren’t close to nothing - if they are, then its gone.

I’m sorry to hear this about your work, but unfortunately the only recovery trick that I really know of is merging. Start a new file, and try and merge the contents of your old scene into it. If you can atleast see the objects list, then most likely it is just one object that may be the problem, so merge them over in groups to isolate the problem. Its worth a try. Also, I know you said that you tried your recovery file, but did you also try the .bak files in /autoback?

Finally, there is maxfile.bak (also in autobak), which is updated every time you save, with the last file that you saved. If you haven’t changed anything, this might still be your last good save and not the recovery.

And I know its a bit late to tout this, but incremental saves. File0000, File0001, File0002…thats why the ‘+’ button is there in the save as box.

Good luck with the files :frowning:

ok, LUCKILY I have the model for the robot ready (on yet another file, sheesh we save a lot)
I only need to make the claw again, oh well only 12 hours or so lol…

here it is, just so you guys see it, if you have any ideas on how to make 3ds max work faster with out hiding object ide appreciate it (f3 dosent help)
it’s slow cause of the materials…

here’s the picture of on of the models:

http://img133.imageshack.us/img133/5608/igolmodel3oa.jpg

if your wondering what makes it so heavy it’s mostly the wheels (but also the main body), which we have used the STEEL material (I think it’s a map though), which is very heavy and the rendering takes forever on close-up.

hey I just saw the other response, I checked the file size it’s 800kb which means the data is still there, still the .bak didn’t help :frowning:

this is so frustrating, for now I’ll work on other things, but I really hope my miracle cure is from someone on this forum hopes.

wow MINT you saved my day =), when I opened the autoback folder it only showed .max files, and you said there’s a .bak file
so I went looking and there it was, in all it’s glory =)

I really appreciate this guys

in any case if someone DOES know how to fix this corrupted files, I think it would be invaluable to all of us :smiley: im so happy

//edit: still can’t save, it corrupts the file

could this be due to the fact there are Xrefed objects in the scene?
if so, what am I gonna do abotu the animation???

Glad I could help =] Try merging everything over into a new file and saving as a new file, that may clear things up.

As for your model, I notice the mesh density is pretty high (duh…you say) - are you using meshsmooth on it?

If you’re not, a quick fix would be to use an ‘optimize modifier’. Turn the renderer setting to ‘L2’, and leave viewport on ‘L1’. Then just fiddle with the threshold until things work a bit faster. Oh and you may not want to be working on the mesh while the optimize is active. To turn off the material in the viewport, you can do it in the material editor by material (fourth button from the left, checkered box button) by clicking the show in viewport button. Finally if you’re really not using some of the objects in your scene, select them, right click in viewport and go to properties. In the first menu somewhere is a checkbox for ‘display as box’. This makes it annoyingly hard to select though.

The incremental save is nice, but does anyone know if you can set up a hotkey for incremental save?

CTRL-S will save without bringing up a dialog box, but I don’t know how to do this for incremental saves.

Even one less step in the process can add up, right? :slight_smile:

I uploaded the .max file (in RAR it’s 40kb rediculously small!) to our server so you guys can take a look at it and try to fix it,
here it is:
http://www.avivrobotics.net/uploads/3ds-max/1.rar

Nim - making a blank file, (file->reset), and merging the contents of your file and then saving a new file worked =]

MiNT I love you =)
I’d give you a hug but your 2 oceans and one continent away :stuck_out_tongue:

thanks a million everyone!