Need Help with Vision Example Code

Our team is quite new to vision. We have downloaded the FRC image onto our raspberry pi. We downloaded the example code for C++. This is where we are at so far. I’d like to build this code through the provided Makefile but I can’t get the .exe to be created. I downloaded Make for Windows and followed the steps on the Read Me text file. I also downloaded the Raspbian compiler and added it to my path. However, when I type “make” into the command prompt, we get an error. It says “The term ‘make’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.” Perhaps, I am doing something wrong. Please help!

If you’re using the 2020 version of the FRCVision image, make for windows is bundled in the example C++ code (it’s make.exe), there’s no need to download it yourself. The README.txt says you only need to install the compiler. You need to make sure your command prompt is in the cpp-multiCameraServer directory where make.exe and the Makefile is located, then running either make or .\make.exe should build it. It’s possible you just need to use the latter.

Note the built executable will not have any file extension.

We still had the 2019 image on the pi (oops). Anyway, we downloaded the 2020 image so we were up to date. We are getting a new error now though. It says “The system cannot find the file specified” making reference to the compiler. I suspect I’m not correctly adding it to my PATH. I’m on a Windows x64 OS. The instructions in the README.txt say to install the compiler. I have only downloaded it. Perhaps I’m not actually installing the compiler, only downloading it. What is the proper way to install the compiler and add it to my PATH?

You need to extract the compiler zip somewhere (eg C:\raspbian), then search in the start menu for “edit environment variables” and add C:\raspbian\bin to the PATH environment variable.

Still not working. Maybe it is not the PATH. Do you want me to send the actual error?

Never mind. I restarted the command prompt and it worked. Thank you!