Need ideas on camera problem

The camera was working and now we can’t get an image on it.

The IP is correct and I have checked and reset the passwords several times. I can connect the camera to the laptop with the crossover cable and connect and see video without issue.

When it is connected to the cRIO and run the code I get no image on the running program or the dashboard. These things worked fine a few days ago, and we can’t figure out what has happened.

I have performed a hard reset on the camera to get back to factory setting and went through all the setup setps as well as tried the auto camera setup program.

We have used the camera many times and had the two color tracking program working. I think it must have something to do with the way the cRio talked to the camera.

Any ideas?

Have you tried re-imaging the cRio. We have had some strange issues with our code compiling and executing that were fixed by re-imaging. I’m not sure if it will actually accomplish anything for you but it’s probably worth a shot.