Needing help with the double solenoid

We are programming in Labview, were having a double solenoind. The issue is that at the moment of testing our robot, the piston is not extending or retracting, but the solenoid is reciving the correct signal from the PCM. Also, the compressor is running correctly. We attach a screen capture of our program.









If you’re sure the solenoid is receiving the correct signal (i.e. the status lights on the solenoid match what you think it should be doing) but the piston is not moving, then the problem is with your pneumatic setup, not with your code.

Remember that the festo double solenoids are air-powered and will not actuate under 25 psi, even if the status lights behave correctly.

What is the voltage of your solenoids? Does it match the one selected on the PCM?

The other problem is that when we manage the solenoid in a manual way, the piston extraxct and retract correctly.

And the voltage of the solenoids is 12V

Do the solenoid status lights turn on and match the intended behavior in code?

Yes when we press the buttom that corresponds in our program the lights turn on and matched with our code.

Could be a bad solenoid, then. Have you tried multiple solenoids?

And, again, make sure that your downstream pressure is above 25 psi, else the solenoids will not change state (even though you can force them to do so manually).

Is exactly the same problem.
It could be the connection of the pneumatic system?

What is your working circuit pressure?

70 PSI.
And also we change the solenoid and it was the same problem

Ok.

I notice in your code that it seems you’re trying to control the double solenoid using two single solenoid controllers.

This is bad practice, since there are states possible for two single solenoids that are not possible for a double solenoid (i.e. both open or both closed). If you attempt to put the solenoid into one of these states, it probably could cause problems/not work (full disclosure: this is not a mistake I have ever made myself, so I do not know exactly what happens if you do it).

Try using the double solenoid option instead of the single and see what happens.

We have resolved our problem.
The issue is that the Festo solenoids recived 24V so we change the jumper of the PCM to 24 V and the piston works correctly.
Thanks to all!

This is certainly enough to pilot the valve. However, you should be aware of:

So, to recap your issue:

  • The lights on the PCB show the right state.
  • The Valves function correctly when manuall electricswitching is used
  • The voltage of the solenoids is 12V
  • The PCB voltage selection is not given.

The first thing to check is the PCB voltage. This is selected with a jumper near the center of the PCB. If you’re reading the word “STATUS” upright, the jumper is above and to the left of the STATUS light. The legend is just below the jumper.

If that’s correct (or has been corrected and still no joy), check the electrical output of the PCB. I suggest unplugging the wire at the solenoid end and putting a voltmeter across the two pin sockets on the cable. Verify that you are getting 12V there when you expect it. If not, check again at the PCB output; you may have a bad wire. If no voltage at the PCB, try another port.
If you’re getting 12V at the end of the wire but it’s not enough to switch the solenoid, about the only thing I can think of is that the connector itself isn’t engaging with the solenoid pins.