Neo 550 DIY repair guide... and don't be dumb like me :)

Recently I got a neo 550 to do some tests with. Recognizing that holding a motor while it spins at a high velocity is not the best of ideas, I decided to build a simple mount that I could clamp to something to hold up the motor. After spending awhile drilling holes in a piece of wood, I went to the hardware store, to pick up some screws that were too long… I screwed the motor to the plate and turned it on, and voila… sensor fault led code on the controller. Knowing that this motor was probably toasted, I ordered a replacement, to prevent my lack of intelligence from costing the team, but in the meantime, I decided to have a crack at fixing this motor - and shocker - it actually worked!

Part 1 - disassembling the motor
the first thing I did was to remove the clip from the motor shaft. I achieved this using 2 small screwdrivers, and a bit of force… I may have bent it a bit, but it should still be fine. underneath it is a small spacer. Lose these parts (or don’t copy me)
I removed the set screws from the back of the motor (in the little cutouts), but I don’t think that matters because I never pulled the shaft out of the back.
To get the back off, I screwed the same too-long screws into the back holes, and tightened them to push it. this worked, however it chewed up a holder thing (big screw? words are hard) inside the motor - a better approach is to use a screwdriver to gently pry it away. after you push it back a bit, you can stop using whatever tool you were using, and just pull and it will slide back. at first it might only slide back to the rear bearing:

pull it a bit more, though, and the back will come off completely.
I removed the ring I talked about earlier, but that is unnecessary - it allows the PCB to slide off the back, which would be useful except that it can’t because of the wires that are attached to it. This picture shows the ring (or whatever):

Also, if you try to take off the ring or whatever, be careful of the smt components on the top of the board - I accidentally scraped one off and ended up replacing it with a regular resistor which wasn’t great.

part 2 - fixing the motor
here are some random pictures of the inside of the motor:

and the resistor I added:

after looking around inside, I discovered the problem to be the sensor ground wire, which had been completely sliced in two. you can see it a little bit in this picture here:

I needed to replace the wire. fortunately, I had some of those hookup wires with the plug end things (sigh) that come with Arduino kits and that sort of thing.
After removing the ground wire from the plug that goes into the controller, I found that with the plastic housing removed from the hookup wires, they actually fit into the plug holes. They don’t snap in, so I just hot glued it in place a little bit.
But first, I removed the old wire from the sleeve, which I could do by just pulling because the wire was in half. Then, I desoldered the half that was in the motor.

because I’m running low on wire spools, I decided it would be easiest to just use two of the hookup wire things and solder them together, so that’s what I did. then I wrapped a bit of electrical tape around it to keep it from shorting or something.
I tried to get it through the sleeve, but I just couldn’t retrieve it at the other end - the things are just packed too tightly, so I decided to run it outside and use the slot in the housing from where they slide all the wires in as a gap to put it through.

Now came the worst bit - I had to actually get the new wire into the hole. This would have been simple if I could have found our solder sucker, but I could not… If you have desoldering tools, use them! but after a long struggle, I was able to get it soldered into place. During that struggle, I did a quick surface-mount-style solder joint and put the top back on just to make sure it would work, and sure enough, no more error code! So after that test, I was motivated enough to persevere and I finally got it through the hole.

I used some hot glue to hold it into place and keep it from sticking out into the stator magnets, but I had to be careful to make sure none stuck out or it would hit the stator magnets. (I did have to peel off a couple of unsuccessful glues, but hey, that’s what hot glue is for). I ran the wire back out the slot I mentioned before and glued it. then, I wrapped it in electrical tape at intervals along the sleeve, to try and keep things tidy.
I put the back back on, which you can do by just pushing (at least temporarily), and plugged it in, and no error code! i quickly reattached the motor to the controller (forgive the terrible solder joints) and tested it and it actually worked!

I never expected to actually be able to fix it, I just thought it would be fun to try… but hey!
here’s a picture of the final product:


How big is the shaft inside the stator? It looks considerably larger diameter than the 1/8" shaft extending outside. I have wondered about coupling the load to the outrunner face to take advantage of the larger shaft diameter. Anyone try that?

We did prototype control panel rotator for Inifinite Recharge like that with some friction material on the outside (the part that slid over the outrunner part of the NEO 550 was all 3D printed).

It never made the robot (we were grossly over weight) but it worked OK in the shop.

It’s a much more durable mount for rotating parts than the tiny shaft if you can handle the size.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.