NEO Brushless Motor Not Spinning

Hello,

Our NEO Brushless motor does not spin even when using REV Hardware Client via USB. The motor makes a noise and then locks up/brakes immediately. The motor is set to coast mode. Any advice?

Thank you!

Are you sure all your power leads are connected correctly to the motor? We had this same problem when we had flipped some of the wires.

Also make sure the encoder wire is connected to the front port on the Spark Max! NEO’s need the encoder connected to run

are you using anderson connectors for power wires? If so make sure they are all connected and properly seated. If one of the 3 leads is not connected it will often not spin.

Thank you. Yes, all the power leads are connected correctly to the motor.

Thanks. So we extended the encoder wires and they have worked before. We don’t get a sensor fault via the Rev Hardware Client.

No, we are not using Anderson connectors for the wires. The motor makes noise when controlled via the USB client, but the shaft is not spinning at all.

Is your spark max connected to your roborio’s can bus? if so disconnect it when you run it with the rev hardware client.link

Are there any listed faults?

Try a different SparkMAX. We had the same problem trying to run a Neo 550. The motor would make whining noises and not move. We could get it to spin by manually turning it to start, but it would only spin slowly and it made what sounded like a grinding noise. We tried several different motors and got the same results. Switching out the SpartMAX fixed it.

Is it possible you could have a really low current limit set?

Yes, we have set the current limit to 5 Amps. It worked before.

No faults are listed. However, since we extended the motor encoder wires, the sensor fault comes and goes.

Yes, we switched multiple Sparkmaxs and we still have the same issue.

If you are experiencing a sensor problem, the motor will not spin. I think you have found your problem.

What is the NEO mounted to? FRC brushless motors (especially earlier versions) are notorious for having mounting screw clearance issues that aren’t well-noted.

If your mounting screws are too long/screwed in too far, it can lock the rotor inside and stop the shaft from spinning. This situation is often characterized by a strange noise too, which leads me to believe this may be what is happening here.

Unfortunately, even if the mounting screws you used came with your gearbox kit (MAXPlanetary, Versa, drivetrain gearboxes, etc.) doesn’t guarantee they’re the right length. Believe me, I’ve run into it myself with both NEOs and Falcons.

Easy issue to solve if you catch it before doing serious damage to the motor, just back the screws out and put a few washers between the screw head and mounting surface on the motor.

Hope this helps!