NEO drivetrain jittering

Whenever we go through zero from -1 to 1 on our controller, the drivebase jitters. This is significantly worse on brake, but still present on coast. Basically, when we go from zero incredibly quickly, the spark Max motor controllers display that they are in idle mode, and will continue oscillating in and out of this until the command is stopped, it goes to zero, then starts again. We have tried a lot of things. For example, we tried a motor that was completely disconnected from our gearbox and it did the same thing, despite theoretically not having any extra resistance. Another thing to note is that our system browns out when this happens, but our smart limits are set to 60. Please help we’ve been stuck on this for days now.

What drivebase are you using? Have you tried ramp rates on your motor controllers.

We are using the basic everybot kit with NEOs. Ramp rates “fixed” it, but it was undrivable.

Are you using standard drive or PID controlled drive? If PID there could be some sensor issues?

Also, we’ve had intermittent issues with jittery NEOS when one of the teensie wires leaving the spark max bundle was poorly connected. Replacing the wires fixed the issue.

Also try using a slew rate limiter instesd then!

We’re using a standard drive. No special stuff really.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.