.NET Framework 4.5 Issue

I am trying to install this so I can use the driver system, and this is the error message that comes up. Can anyone help me?

OS Version = 6.1.7601, SP = 1.0, Platform 2, Service Pack 1
OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
MSI = 5.0.7601.18637
Windows version = amd64_windowsfoundation_31bf3856ad364e35_6.1.7601.17514_none_615fdfe2a739474c.manifest
Windows servicing = 6.1.7601.17592
CommandLine = C:\c4cbd044004238cfc6b5139558\Setup.exe /x86 /x64 /web
TimeZone = Central Standard Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism

Operation: Installing
Package Name = Microsoft .NET Framework 4.5 Setup
Package Version = 4.5.50709
User Experience Data Collection Policy: Disabled
Number of applicable items: 9
Exe (C:\c4cbd044004238cfc6b5139558\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (C:\c4cbd044004238cfc6b5139558\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
MSI (C:\c4cbd044004238cfc6b5139558
etfx_Full_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4.5 Setup_20150220_152229737-MSI_netfx_Full_x64.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:19).

What specifically are you trying to install? If you are trying to install an application that is also trying to install the .NET framework, you should try and install .NET separately.

You can download the .NET framework 4.5 from Microsoft here:
http://www.microsoft.com/en-us/download/details.aspx?id=30653

The driver system requires the .NET framework, we tried downloading it from the link above and it does not install correctly.

A quick Google of the error code found this Microsoft KnowledgeBase article:
http://support.microsoft.com/kb/976982

It appears that MSI is interfering with it.

Hope this helps!

I’ve never had this issue with .NET before, but it might be worth looking to see if you have any additional versions of .NET installed (3.5 is built into Windows 7). It’s possible that you have a corrupted install of .NET, which is preventing you from installing the new one.

Search “programs and features” in the start menu and click enter. Scroll down to Microsoft .NET Framework and see what versions you have installed. If you have an existing copy of 4 or 4.5, try uninstalling and re-installing it.

Hopefully that works (or one of the other suggested fixes above). Otherwise, you might have a bigger issue at hand.

So far none of these solutions have worked, even Microsoft’s official “Fix It” tool hasn’t fixed it, we have decided to try and reinstall Windows from the factory CDs (The kid’s only had windows for 2 weeks and has only installed Minecraft and Chrome).

Give the offline installer a shot first:

.net 4.5:

http://www.microsoft.com/en-us/download/details.aspx?id=40779

or

.net 4.5.2:

http://www.microsoft.com/en-us/download/details.aspx?id=42642