NetBeans Deploy Code Hang

Hi Everyone,

We finished our robot code, connected the Classmate computer directly to the cRIO via Ethernet cable, cleaned/built the code in NetBeans. We then told NetBeans to run/deploy the code, and it soon hung at the OTA Server stage. After researching the problem, I found that this was normal and we re-deployed the code, only for it to hang again, at the following two lines:
[cRIO]edu.wpi.first.wpilibj.networktables2.server.ServerConnectionAdapter@15 entered connection status: GOT_CONNECTION_FROM_CLIENT
[cRIO]edu.wpi.first.wpilibj.networktables2.server.ServerConnectionAdapter@15 entered connection status: CONNECTED_TO_CLIENT
We then canceled the process, after it stayed at the same line for a few minutes and tried driving in Teleop mode. The three lights for Communication, Robot Code, etc were all green but when the robot connected and we hit Enable, the area near the bottom left on the Driver Station told us there was no robot code and nothing on the robot worked. Our electronics people have double checked all connections, and have concluded that there is nothing wrong wiring wise. I have also been back searching here on Chief Delphi for a solution and have not found anything that worked so far. Can anybody give us a solution please?


I would guess that your code is throwing an exception when you enable teleop. If you don’t cancel the netbeans deploy, the exception backtrace will be shown in the output window.

Do you have a second cRIO that could temporarily replace the one you are using? Not permanently attached to the chassis or anything – just a quick replacement. If you are able to deploy the code to the second cRIO, the problem is likely some bad hardware in the first cRIO.

I am new and don’t have first hand experience with your problem, but just giving a general troubleshooting suggestion.

Thanks for your suggestions guys,

@Joe Ross: We will try not cancelling the deploy when we are ready for a another test in a few minutes (mech and electrical have the 'bot right now).

@VARobot: Yes, we do have a second cRIO, but because it is a cRIO from LogoMotion, and thus much bigger, we do not have the space for it on a more permanant basis. If it is a fatal cRIO problem, considering our state scrimmage is in a few days and bag-and-tag in a week, we are in a pretty bad spot. Is there any way it is not a fatal cRIO issue? I have seen the exact error codes I listed in several other threads, and have seen possible solutions there. I do not mean to disrespect or dismiss your help, in fact I am very grateful for it. I just want to avoid having to buy another cRIO if at all possible.
Can anybody else weigh in here?

Hey everyone,

I am afraid that we have not solved our problem yet. I tried the NetBeans debugger despite the fact that but just got a long stream of errors related to build.xml and configure.xml under the sunspot FRC SDK and the debugger failed… Next when the robot is ready for testing, I will try keeping NetBeans’s deploy window open while we try to drive although I don’t know what that will solve. Does anybody have any ideas?