Network Tables not propagating from RoboRio


#1

We are doing our vision processing with Python cscore on an odroid processor (small linux box). Our robot code is java. We are using NetworkTables to send data between the two.

We are monitoring the network tables via OutlineViewer.

In the robot java code, we’re using SmartDashboard.putString(’/vision/active_mode’) to change the settings in the camera server. In the vision code on the odroid we’re using the ntproperty (’/SmartDashboard/vision/active_mode’).

When the robot code changes the property value, we see it in OutlineViewer, but the odroid python visionserver does not see the update. However, if we change the property in OutlineViewer, then the visionserver python code does see the change.

We even tried putting in a check in teleopPeriodic() to change the property every two seconds. The OutlineViewer updates, the code writes out the property to the riolog, but the visionserver still doesn’t see the update.

Any suggestions are appreciated.


#2

This sounds like the same issue as https://groups.google.com/forum/?utm_medium=email&utm_source=footer#!msg/robotpy/dZcRxs6WAFA/eZIJRWW0CAAJ ?

Don’t put a leading slash on the SmartDashboard string.


#3

Thanks. I was actually sitting next to the guy who posted on google group. He posted there and I posted here.

Thanks for the help.