New Command Framework Missing from WPILIB Install

I’m not sure if I’m the only person with this issue, and I know it’s still really early on, but my imports for wpilibj2 in Visual Studio cannot be resolved. We’d like to start using the new command framework. I know that WPI says that it is included in the second vendor library, but they also say that it comes packaged in the installer. I created a new project with the latest release, but still no luck.

Unsurprisingly, upon further inspection wpilibj2 is not installed. What is strange though, is that the tool will let me create a new class from one of the new Command templates, but they aren’t actually in the install! I could install it off of their Github, but I wanted to know if anyone else running into this issue?

Just a quick test – did you try to build your code? Because sometimes IDEs complain that stuff “cannot be resolved” but then the code builds just fine.

Does the vendordep file for the new command framework exist in your project’s vendordeps folder?

1 Like

I too am not seeing the new command framework (wpilibj2), neither in the IDE, when compiling or in the java dependencies window:

It you just created a new timed robot project, it will not contain the new command setup. New commands is actually a vendor dependency for 2020. Easiest way to get is is if you used the wpilib installer run manage vendor libraries, select the option to install new offline libraries, and select the wpilib new commands dependency.

3 Likes

Wow! That solved it, thank you. I knew that it was a vendor dependency, but I thought that the installer would install it into the project by itself. Thank you, this was a really quick fix now that I know.

1 Like

It will install it into the project if you create a new project using the command-based template instead of the timed robot template.

If I had created the Command-based template, would the feature of the set frame time from TimedRobot still be included?

Yes. The command-based template is built on top of TimedRobot.