New cRIO Image doesn't Recognize old cRIO

So, the like the title says. The new imaging tool can’t find the old cRIO. I tried using the old imaging tool, but it failed. It had the option for both the old one (FRC_2011_v28) the new image (FRC_2012_v43), but the new one went away after I tried using and it said that it couldn’t find the image.

Any suggestions?

As said several times by our control systems crew also, its a pain when trying to work on our older robots.

The cRIO we’re using is from last year

Unable to complete operation because of unexpected error:
Error 7 occurred at File/Directory Info in ConfigUtility.lvlib:ReImageTarget.vi->ConfigUtility.lvlib:Dialog.vi

Possible reason(s):

LabVIEW: File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS, and / on Linux. Verify that the path is correct using the command prompt or file explorer.

C:\Documents and Settings\Sony\Local Settings\Temp\lvtemporaryd_703222\CRIO

We had the same problem. Make sure you turn your windows firewall off. Otherwise it causes problems. You may also need to go into the properties of your ethernet adapter and change the last digit inside the TCP/IPv4 for the static ip to .2

We just went through the drills of formatting old and new controllers.

TWO things you need to do.

  1. you must go into the PC control panel, System/Hardware/Devices or something like that and temporarily disable ALL network interfaces except the one connected to the cRio. This interface must be connected to the cRio using a crossover cable, and the interface must be configured with an IP address compatible with the address you are using on the cRio. 10.xx.yy.100 for your PC is safe where xx.yy is your team number.

  2. the module/slot arrangement is different than last year. the old cRio must have the same module/slot arrangement as the new one. module arrangement should not affect imaging. If you do not rearrange the modules per the instruction the signals will not get from the cRio to the digital sidecar.

Ed,
This makes complete sense when I compare our lack of response from the old cRio after imaging it last night. I will absolutely try this process this afternoon.

Now, I have a question. Where is the documentation that explains this? Obviously we missed reading it.

Getting Started with the 2012 Control System
page 12 has the module organization for both the old and new cRIOs.

Thanks Mark, that is as obvious as the nose on my face.
I know I’ve looked through that document many times, I just never read it front to back. So, this bad is on me.
BTW, the heading on those two columns are reversed, but that doesn’t stop it from making sense.

OK, progress can now continue!

I confess I haven’t actually read it word-for-word myself yet, I just browsed it…::rtm::

I will read it thoroughly, I promise.