New Vex Ultrasonic Sonars not working

This year our team is using a lot of ultrasonic sonars (4) to monitor our distance from walls and hopefully get acurate positioning during the hybrid period. In order to accomplish this we bought three new vex ultrasonic sonars, manufactured Nov, 2007.

We have an ultrasonic sensor from a previous year, manufactured May, 2005 which works perfectly. When we run ultrasonic code and plug in the old sonar, the terminal starts obediantly spelling out how far away from a wall we are. But when we unplug the sonar, and plug in one of the new sonars, nothing works. We can accurately position something up to 4 inches away, and then everything starts timing out.

The code we are using is straight from Kevin’s site and Chief Delphi itself.

I wouldn’t mind if the new Sonars had some different documentation as the old ones, or if they had different manufactures, different part numbers, or anything. But as far as the rest of the world is concerned, these sonars are the exact same as they have always been.

If you have also experienced this, if you have a solution/workaround, or any information please post it. If you need any more information I’ll be glad to provide it. Thanks in advance

This is going to sound stupid, but its just a sanity check… have you tried swapping the input and output wires connected to the controller? We wasted an incredible amount of time when we first hooked ours up last year, as they were backwards. The whole board lags incredibly/won’t run if they are incorrect.

Also, double check any solder points or female-to-female PWM cables.

We ordered 4 rangefinders off VexLabs last week and successfully implemented them without any problems today (EasyC Pro, though), so otherwise I don’t know what to tell you.

No, we even kept the same cables. Literally while the code was running we tried the sonar, and got valid distance values. Then while the RC was still running, we unplugged the sonar, and swapped it with one of the new ones. Immediately we got invalid distance data. It’s not a problem with resetting or anything, because afterwards, while the RC was still running, we unplugged the new sonar, and plugged in the old one, and received valid position data. We followed the same procedure for all three of the new sonars. So we know for a fact it is a problem with the sonars.

If you recently purchased working sonars, it’s probably a defect in ours. I’m a little unwilling to accept that too quickly though, because it’s three sonars, not just one.