I just installed the FRC Game Tools from NI Package Manager. Everything was okay until I tried to install Docker, which then prompted me to reboot to finalize the installation. Every single time I reboot, I got a BSOD with the error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED, and what failed was nipcibrd.sys - National Instruments PCI Bridge Driver at C:\WINDOWS\System32\drivers\nipcibrd.sys. I tried disabling nipcibrd.sys with Autoruns, but then my PC would get another BSOD with INACCESSIBLE_BOOT_DEVICE.
Can anyone help me resolve this? Thanks a lot.

This thread over on Ni’s website suggests that Upgrading to PXI Platform Services 20.0 was able to fix the issue for at least one psrson. This post on another thread suggests updating my LV 2018 packages and a windows update that should should already have installed by this point (1909).

For that 2nd post, earlier in the thread they discuss different version of that nipcibrd.sys file that appeared in 2015 and 2018, with the 2018 version being older than its 2015 counterpart. They dont give any information about how to distinguish them though, or where they found the update.

If its still persisting after trying these, id make a thread over on the NI forums in the FRC section.

I have upgraded PXI Platform Services to version 21.0, but it didn’t fix the issue.
I think I’m going to make a thread on the NI forums.
Thanks for your advice.

Update on 14/12/2021: Installing Optional Updates in Windows Update settings fixed the issue for me.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.