no CAN comm\damaged hardware

today we tested our electronics plate for an off-season project (first time using CAN to control motors, using 6 talon SRXs) but the status LEDs on all of the talons and on the PDP were indicating that there is a problem.
they were altering between two states:
the first one was slow red blinking, indicating damaged hardware, and the second one was altering between red and orange, indicating that there was no CAN communication.
every wire is connected where it should be, and they are all soldered properly, but still, the status LEDs indicated those problems.
I am 99% sure that all of the devices are not damaged because we took them of a robot that did worked fine (with PWM communication), and they probably were not damaged during the process…

anyone has a clue about what the problem could be?
thank you and good night!

To clarify the blink codes, alternating between off/red is indicating that the CAN bus/PWM is not detected and alternating between red/orange is damaged hardware. If you guys haven’t been already, refer to the Talon SRX user-guide.

The TalonSRX’s may not properly configured and multiple Talons may have the same device ID because of that. The roboRIO web utility can help make sure all Talons have unused device ID’s so they don’t get confused on robot boot-up. Also, verify that the RoboRio on the robot you guys moved the speed controllers has the latest firmware and imaging.

If you guys have time to put the speed controllers back on the robot that they worked on, I suggest you guys try that to ensure that the speed controllers aren’t actually damaged.

thanks for the quick reply!
i probably mixed the blink codes in my head :stuck_out_tongue:
we never used CAN for talons, so every one of their IDs is probably 0, which might cause this problem. i will change it tomorrow.
anyway, do you think this problem will cause the LEDs to indicate damaged hardware?

No problem!

I’m actually not sure whether it will cause the LEDs to indicate damaged hardware. But since you indicated that you guys pulled out working Talon SRX’s in good condition, it seems odd to me they would suddenly blink like that. Also on the previous robot you guys used the Talons via PWM and never have used it in CAN, so configuration could likely be the issue.

Tell me how trying to resolve it tomorrow goes!

IIRC switching between orange and red happened to us once when we accidentally crimped one of our connectors backwards, resulting in the last segment of the CAN bus that ended at the PDP being connected backwards (yellow to green and green to yellow). Double check the colors :slight_smile:

This gives me an idea…Maybe try using just one Talon and see if that works? Then add another one, and another until it stops working. I haven’t worked with CAN extensively, but that seems like it could help you find out if the ID’s are set up incorrectly.

I changed the IDs so they won’t override each other and it is working now.
thank you from team PRIMO 4586!

No problem! Glad it worked.

Our team had a very similar failure. TalonSRX plugged into the CAN bus. Talon flashes red (“CAN bus/PWM is not detected”) and nothing shows up under the CAN Interface icon in the RoboRio System Configuration web page.

Problem ended up being a failed crimp. Curiously the PDP continued to flash green (OK). I hope this helps someone out.

our team’s PDP failed one red and one yellow constant light, no blinking
we changed boards and all good but would like to fix / repair the other board
maybe the 120 ohm resister?

You best bet is to contact CTR electronics support. They can help you troubleshoot and tell you if the board is repairable: [email protected]
Support Request PDP

We just had the same issue when setting up our Talons for the first time. We had a kind of complicated CAN setup, and we had not set the CAN IDs yet. One of the talons blinked orange and red and the other just blinked red. We will see if changing the IDs solves the problem (I cannot imagine that the first one is fried, as all of the wires were plugged in correctly).