No Code Error

I am using Windriver C++ and have installed all of the updates. My development PC has been set to the ip 10.14.14.6 (or whatever it was supposed to be, I am working from home right now). I have installed the Driver software on the development PC.

I compile the example code in Windriver and use the FIRST downloader to upload the code to the CRIO. It doesn’t tell me if it worked, but I assume it doesn’t because when I restart the cRIO I get the no Code error from the Driver software.

Any Help?

This can happen for two reasons - you don’t have code (sounds like you do) or the code is failing to execute.

First, check that the FIRST Downloader in Windriver is downloading the program you expect and that your team # is set properly. Both of these are set in Windows->Preferences->FIRST Downloader Preferences.

Failure to execute is often caused by a mismatch in version between what your code is compiled against (WPILib in Windriver) and the cRIO’s FPGA image on the robot.

Have you downloaded and applied all updates to Windriver?
Have you imaged your cRIO with the latest C++ image version (version 19)?

Update everything, recompile, and re-download your code. Restart your robot. If you continue to have problems, it is helpful to either:
A. Undeploy the program, reboot the robot, and load your code using the Debug facility in Windriver – this will give you the ability to get any errors back as the program is loaded, and also to know your code is getting there.

-or-

B. Attach a serial cable to your cRIO’s serial port, turn on the “console out” DIP switch on the cRIO, reboot your robot and watch the console messages on a terminal program on your laptop. This can give further details.

Well i get some error codes, I suppect they are related to hardware failure, but I have to rule out the software side first.

I attached a screen copy of the errors.

This error get thrown when I try to debug from Windriver following the instructions from the Getting Started with C.pdf document





Does anybody know what this error is about?

You say you installed all the updates, but did you reimage the cRIO afterwards? I’ve never used C++ on an FRC robot (I’m a LabVIEW guy), but those errors make me think that you’re trying to run 2010 code on a 2009 image. Make sure the cRIO is updated with v19.

Yes, v19 (the driver’s station confirms). Windriver has also been updated (it doesn’t communicate if it’s not updated)

We had a similar problem, where we could load code to the robot. The driver station indicated communication, but no robot code.

We tried reimaging to v19 a second time, as well as updating the workbench a second time with no positive results. One of our programmers found that the update.cmd file, found in WorkbenchUpdate20100107.exe, only installs the update to the default filepath. You can change the install paths for the update to your actual install directory. You can change update.cmd to install to the correct directory, or you can copy the contents of the update to your Windriver directory and overwrite the old files. The first method you need to run update.cmd after you make the change.

Below is the snapshot of the change we made in notepad++.





Well mine is in the defualt install path, I am just going to try another computer setup and see if I can narrow the problem down (computer, cRIO, installation error, my presence) etc

I’m having exactly the same problem. I have re-installed everything at least three times and installed all updates, but the execution fails with the same error message as previously described.

Just out of curiosity, what operating system are you on? I’m on Windows 7, but I don’t think that should affect anything.

Well I have narrowed it down to an install error, not a Windows 7 inherent error. So check for problems caused by installation (maybe UAC or the like), i am using the classmate with a Windriver install for now.

However the only project I can build (and not all the time correctly, (random error that aren’t part of the ISO C++ Standard) is the sample project, so i blame this level of malfunctioning on FIRST.

Well I have narrowed it down to an install error, not a Windows 7 inherent error. So check for problems caused by installation (maybe UAC or the like), i am using the classmate with a Windriver install for now.

However the only project I can build (and not all the time correctly, (random error that aren’t part of the ISO C++ Standard) is the sample project, so i blame this level of malfunctioning on FIRST.

I too blame this magic “FIRST” creature.

What do you mean that it doesn’t build correctly? The same code built multiple times gives errors? I don’t think that the code would be compiled again if unchanged.

Unresolved symbols dealing with the FPGA at runtime is usually caused by a mismatch between the running cRIO image version (which contains the FPGA image and the runtime binary library that completes the binary built in WindRiver) and the version of WPILibary on your development computer that your binary is compiled against.
Less often it can be caused by other issues.
You said you narrowed it to “an install error”. Could you be more specific about what you found to help others that may be encountering the same issue?

I have a question, does anyone have actual compiling code for this year using the ItreativeRobot class yet? While the rest of the team is building the physical robot I’m trying to figure out this years WPILib by porting the code from our 2009 bot to 2010. I’ve completely pulled the camera sections and updated my Dashboard/DriverStation methods to the versions used in the 2010 Vision Example. However, I still get a persistent No Code Error on the Robot when trying to use this code. I’m thinking that I may have some small thing that has been left behind not being caught by the compiler. Since I can’t find a 2010 IterativeRobot example included in the WindRiver examples I’m in need of some (working) IterativeRobot based code. Thanks a bunch :slight_smile:

There is a semi random error in the WR updater, it extracts the files to a temporary folder, but doesn’t move them to the actual folder. this might be whats happening.
I think the update folder is in C:\ so look around (or search CD)

You can add us to the no code error issue too.
we are running the wind river tools
We tried deploying the default code and it seemed to download ok but the driver station said no robot code…
Crio has the v19 image…we updated the workbench to the latest update 20100107 . we cant check error messages via the serial port because the crio is not talking back to the laptop for some reason.

Here’s the catch…we also tried using a laptop with last years tools on it and we were able down load and run the default program

Any Clues??? I sure didn’t plan spending the first three weeks of build season getting the tools to work…:mad:

Brian
Team 1714
Sr Firmware Engineer
Rockwell Automation

Based on your screen shot, the WPILib you are linking against is expecting FPGA version 2010 revision 1.1.0 (which has GUID E0037A37F5C5D7F6A40E3C03D3CE51DD, which you can see in the missing symbols). This version was shipped on the DVD distribution for 2010. The cRIO image v19 includes FPGA version 2010 revision 1.3.0 (which has GUID AD9A5591CC64E4DF756D77D1B57A549E).

Have you tried the new NetConsole interface? It allows you to see the console without a serial port (which is especially handy if you are using the serial port to run your Black Jaguars!)

If last year’s code runs on the robot, then you haven’t updated the image to v19 successfully.

We are having the same error. We are using labview. It connects to the robot and it successfully deploys code, but on the driver station says no code

Are you logging out of developer and quitting LV in order to run the DS? Quitting LV aborts any cRIO code it is debugging.

Another thing that can cause this is having the wrong cRIO image, v19 is the latest, and the diagnostics tab on the DS will show the version.

Greg McKaskle