No communication with Rio through driver station

Our team has been working on setting up our robot/Rio and programming laptops, and have just installed all the 2020 NI software and WPILib tools for code development. When connected over USB/Wireless we’re able to see the Rio (green light and IP in driver station), but we don’t get lights for communications in driver station.

  • Rio image version is 2020_v10
  • Rio firmware version is 6.0.0f1
  • Driver station version is 20.0

Once putting the 2020_v10 image on the Rio we were able to successfully build and deploy code to the it, but it still doesn’t show comms (or code) in driver station. We’ve reinstalled the image/firmware for good measure, and also tried on two separate updated laptops to no avail. We’re able to ping the Rio as well as view its web interface.

Is there some configuration step we’re missing or something else would should try?

Zach Brantmeierz (6574)

1 Like

What code did you deploy? Was it a fresh project created from the 2020 wpilib plugins for VSCode? If not, please try that.

I’ve had this happen for various reasons, including:

  • Windows/third party firewalls were enabled
  • Connection was set as a public network
  • Laptop software was interfering (if possible, dedicate a drive laptop and only have the update suite and WPILib installed)
  • Radio flashed/configured incorrectly or incompletely

When you attempt to connect the driver station to the roboRIO, open the second (diagnostics) tab on the DS. What communication indicators are lit? Please specify which method (wireless/USB) of connection you are using when you do this.

1 Like

Adding to above post, definitely check the firewall, especially on a Windows laptop.

Also, try connecting through Internet instead of USB or wirelessly.

It might be nice to see what error messages show up in the FRC driver station console.

For us, driver station didn’t actually update and we had to uninstall/reinstall(which you should do anyway when updating but /shrug).

Did you set the team number in the driver station?

To update all in the thread, we got it working. Some fussing around with the firewall settings and a couple other small things got us working. Our team laptops run through the school’s system, so a few firewall things need to be resolved yet but we got things working both on a mentor laptop as well as both of the team laptops we are hoping to use consistently.

Thankfully, our district tech coordinator is one of our team mentors, and so I think we can get those last few things handled. Thanks to everyone for helping out with this!

Quick edit: direct questions about how we got it working to @brantmeierz


Very late reply, but just to wrap up the thread for anyone finding this post with a similar issue: allowing NI software/FRC driver station through the Windows firewall fixed our issues.

One of the top 3 things I check as a CSA/FTAA when helping teams with connectivity issues is that the firewall is completely disabled.

I neglected to check it until fairly late because the laptop’s firewall settings hadn’t changed from 2019 to 2020, so I figured it was some failure in setting up the 2020 software tools; the 2020 driver station must just be even more sensitive to them. In retrospect though, for how many times the Windows firewall has caused our team problems I’m definitely putting it on the top of my personal priority list for things to check if there are software/comms errors.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.