No console output in Eclipse

Hello, so I just reset my laptop (Windows 10 Home x64) because it wasn’t running well. When it finished I reinstalled Java (the latest version), and tried running a robot program in Eclipse to make sure Java was working. But it no longer showed the console output while compiling the program for the roboRIO. Even though the robot isn’t plugged in, you can see that the program runs for a while, and then quits when it can’t find the RIO - but without anything pushed to the console. It is the exact same Eclipse (neon x64) and workspace as before. I even tried downgrading Java to the version that was installed before when it was working (8u66 x64), and I also tried older versions of Eclipse, but it still did the same thing. I also tried the 32 bit version of Java. What else could be the culprit? if it is the same Eclipse, Java version, and workspace, why wouldn’t it work just like before?

Other robot workspaces have this issue too, but running basic Java console programs works fine.

I’ll try pushing code to the robot tomorrow to confirm that the code is actually running, and post an update.

EDIT: Yes, the code deploys to the robot normally, just without showing anything on the console.

Did you ever find a fix for this? I’ve even tried reinstalling eclipse and it hasn’t helped.

Unfortunately, I haven’t found any solution other than reinstalling Windows. I did figure out that it may have to do with Avira antivirus, though; it didn’t start happening until after I installed it (uninstalling it didn’t help, Eclipse is still screwed up).