No devices showing up on Tuner X

I formatted and updated the roborio and reprogrammed the radio. On the FRC driver station when I connect to the robot comms shows up. However when I connect using Tuner X none of the motors show up despite them being properly electrically connected and flashing the right colors. Does anyone know why?

I believe that you have to upload code to the RoboRIO with the phoenix dependency installed or just start a Temporary Diagnostics Server in Tuner X.

I ran a temporary diagnostics server but nothing showed up. We think it has something to do with roborio because it gives the error of roborio can not be found when trying to deploy code. However there does not seem like there are any updates or anything and we think its formatted correctly.

Post a screen shot of your Rio firmware? Also, plug into the Rio via USB to take everything else out of the equation.

I tried editing the start up settings and received this message.


Also apparently nothing shows up for Firmware version…not sure why

Will it let you format it?

no

Rio 1 or 2?

rio 2

Does it have an SD card in it?

yes

If you put the SD card into a PC is it ok?

We put the SD card into a computer and this popped up.

It does not allow us to select any image. The only one there is greyed out.


When we click the SD folder icon, this is what pops up. We tried going into the SD images folder and extracting the disk image file but that also did not work.

1 Like

You need to use etcher to take that last file in directory structure and “burn” it onto the SD Card.

do we need to use Debian (.deb) packages or Red Hat (.rpm) packages?

Nope.

We had a similar problem a bit ago. Check that all your firmware on all hardware connected are updated and then update your code. Our issue ended up being that the Spark MAXs didnt have their firmware updated and that was repeatedly crashing the code. The temporary diagnostic server usually does not work.