No power ( torque) to our Elevator

Running our robot most of the day at the fair we ran into a problem where our elevator didn’t seem to have enough torque to drive the system.

First thought bad motor. Turns out if we apply direct 12 from battery the system works.

Second thought bad TalonSRX. After replacing the TalonSRX the system still has no torque.

Could it be a bad PDP channel?

System is running motion magic using an analog break out board and 10 turn pot for feedback. Ill have to open up Phoenix tuner to look at what the feedback is returning but i suspect that to be unlikely a problem.

Do you have a voltmeter? Checking the PDP channel is not difficult.

We’ve burned PDP channels a few times.

The PDP is a hunk of metal. As long as the SRX appears to have power throughout the process (lights) then it’s not the PDP.

Speaking of the Talon lights, what do those look like? Those will tell you everything you need to know about what the Talon is outputting, and from there you can make guesses about what’s wrong. I wouldn’t be so quick to rule out the sensor.

Have you checked the driver station logs? See if it says it’s drawing current from the ports for the elevator motors.

Ds logs barely register any current. 5-10 amp at a glance.

SRX leds transition from yellow to green or red as commanded. Limit switches are in play. I didn’t observe these to be triggered.

This all went down with about 45min left of our area being open. And after 12hr at the fair the day was OVER.

As i was sound boarding the original msg that sensor idea popped into my head. Pits were closed and i was 3 miles away from the robot.

You can use constant-force springs to help your motor for pushing your elevator

Already done.

This robot has run through One regional, an Off-season, countless demos, and a full day at the fair before this failure. There are two 16lbs CFS installed. With out the motor and gearbox installed the system nearly raises on its own, there is maybe 3lbs of force.

but thanks for putting some thought into the conversation.


What was your battery voltage with the robot not moving and with the elevator going up? Was it like that all day or only after many hours of running at your demo?

We rotated through batteries. Drive train is still responding with 6 mini Cims. Elevator is a AM Redline

Thanks so far for the ideas to look at. We will make sure to report back tonight if or what we found

It could easily be the POT. Had one of those go bad on us back in 2013 - we had a 2-jointed arm connected to a winch, all running through a feedback system so everything worked smoothly together. Programming it was a huge pain, but a cool little bot. Anyways, fall of 2013 we were in Manchester for the Alpha Test weekend for the RoboRio and things weren’t working right. Turned out the pot that had made it through two regionals and two off-season events went bad. Replaced it, re-calibrated everything, and no more problems… with the robot. The broken pot ended up in my pocket, and then from there into my suitcase (probably when I emptied my pockets while waiting in line at the airport to go through security). The TSA saw it on the scanner and I got to spend a good long while talking with them because it was “suspicious”. Ugh.

But I digress. Even a slight misalignment on the pot will eventually wear something out and break it internally. You won’t be able to see it, but you can measure the difference with a multimeter while manually moving the mechanism - unplug the pot and measure the resistance across the signal and ground pins. You should see it change from near 0 ohms on one extreme to near the ohm rating of the pot on the other, assuming you’re using most of the travel of the pot. While the elevator probably has enough force it in that a broken pot wouldn’t impact its movement, if it is busted and you pull it off, you’ll probably be able to tell just by turning it by hand - ours was really stiff and felt like something was grinding.

After that, I would look at the power and signal pathways. Based on the LED’s on the talon, it sounds like it’s getting signal and power just fine. Check the pot pathway assuming it’s plugged right into the talon. Check the power pathway from the talon to the motor as well. If you have a connector (power pole or something else) in that pathway, there’s a chance that the heat of the day, combined with constant running, caused some problems there - I’ve seen a wire for the RSL burn up during a parade before, so anything can happen! If the casing of any connectors deformed from heat buildup, it could have essentially disconnected the motor.

If you have a o-scope, you could check out the output of the talon directly. It’s actually a pretty cool learning exercise for the kids to see how the output waveform changes as the speed you’re commanding it changes, and then how hooking a motor up to it averages out the voltages so you don’t even see the waveform anymore.

1 Like

Thanks for the stories and experience you have worked through. Yes we will have to check the pot function. I would think the elevator would run away or act more erratic if the pot was malfunctioning.

We have a few days to get it up. Friday and Saturday are the big VEX tournament and we want to have our FRC bots up.

It turns solid green or solid red? If not, does it blink at about the speed you expect to see?

If it is blinking, are you positive that it isn’t the blink code for “limit switch hit”? We had a problem with regard to where we plugged in our limit switches this past year and the similarity between the “limit switch hit” blink code and the “going in reverse” blink pattern made it hard to diagnose. We assumed the talon was trying to drive the motor but when we looked at the blink closer we realized that it was just telling us that the limit switch was triggered.

Yes we need to take a minute to really understand the blink codes, but the elevator starts to raise ~ 2" then stalls when driven off the SRX but plows to the top if connected to the battery direct.

Has the system been tested in open-loop? (code strickly to drive the talon open loop, a factory reset call would be good as well)

I would always take that component out of the equation before going to the trouble of getting out a multimeter and checking currents/voltages.


Great idea to drive in percentoutput!. ConfigFactoryDefaults is implemented on all our SRX 'S


Good or bad we got to the fair last night and everything is working now.

1 Like

If you were running it all day yesterday, maybe a component (maybe the PDP fuse since running the talon directly on 12v worked as expected?) was running hot from running all day and current limiting? Kind of grasping it straws though

We ran the motor directly, bypassing the Talon but yes the idea is the same.