No PWM signal to speed-controllers(code problem probably)

Every year, tor the homecoming parade, our team makes a robot to distribute candy, and this years robot it having some problems. When we go to do our first test of the code and bot together nothing happens. The code deployed and ran correctly, but when we enabled it, the speed controllers(jag/victor) remained flashing yellow(no PWM signal). We tried a new digital sidecar, new PWMs, new battery, new everything. Nothing happened until we tried to run the default code(the one from frc that you get when you start a new project) to see if it was a code problem and what do you know it worked. So now we are 95% sure that it is the code, but we don’t know what about the code is the problem. Has anyone had a similar problem and found a solution, or have and troubleshooting tips.Oh! Also, besides the speed controllers not initializing/light turning solid there was one other thing. Anytime we enabled the robot the 5v light on the digital sidecar goes out. Is is on any time the robot is not enabled but goes off the second it is. When we ran the default code the light dimmed but stayed on. Thanks for the help. :slight_smile:

Sounds like a short on one of the DIOs that the code enables.

Try disconnecting all DIO and relay cables to see if the 5v light stays lit.
If it does, then reconnect each DIO one-by-one to see when it goes out.

Just a little update on this issue. It turns out it was an electrical problem. They hooked up the sidecar to the 5v output instead of the 12v. :smiley:

Thank you very much for letting us know what the problem was and how you fixed it.