"No Robot Code" error? plus other issues...

we’ve tried uploading the program to our cRio, however whenever we go to the driver station, we still see the “Robot Code” LED as red. it’s not detecting our robot code even after deployment, any idea why?

we followed the video tutorial here:

also, i don’t know if this is related to the coding problem, but our motor controllers are not responding what so ever. we’ve tried both the victor and jaguar motors and both are responding the same way (just blinking, no change in pattern).

any help on this is appreciated.

— we are using Labview; already updated firmware / driver + labview to latest. —

UPDATE Issue has been resolved. see below for our (“oh duh” moment) resolution

I didn’t watch the tutorial, but there are two ways of getting code on the robot. For development, I’d recommend hitting the run arrow on the RobotMain VI. It will put up a dialog listing the work to do and any issues it runs into.

To put the code onto the robot for a competition, once you know your code works, you deploy and set the App as startup. You may not be doing the second step. Also, it should state that it needs to reboot the cRIO. You don’t mention that step, so perhaps you are only deploying.

Greg McKaskle

Apparently the issue was the driver station…

nowhere in the documentation (at least that i could find) did it state that you had to run the driver station program along side the debugger/compiler… (start / all programs / FRC driver station). i was under the impression it would work by just hitting the little arrow button in the compiler when hooked directly to the cRio (little did i know…)

everything works now. got the code working (with a few changes between the tutorial’s beta version and the most recent version). it’s a very VERY basic program for just tank-drive movement… if any other rookie teams (who are still struggling with the coding in labview) want a copy of our template, just email me (see below) and i’ll post a copy on here and / or email it to you. :smiley:

Your original post said the “Robot Code” LED was red, so we naturally assumed you were running the Driver Station application. If you hadn’t given that indication, you would quickly have been advised to run it exactly the way you figured out.