No Robot Code Error

I have a tank drive robot that I’ve been using to test code. I just installed all the updates to the RoboRio and Eclipse. They have all been updated as far as I can tell.

I uploaded new default arcade drive WPIlib code to the robot and it claimed to have been successful. However, when I go to the Driver Station, there is no robot code. There are no errors other than “ERROR -44019 FRC: the mDNS service is slow to respond. Check firewall settings.”, but I don’t think that is what is causing this problem as I have seen that same error before.

Right before I updated the roborio and eclipse I had been running the robot with other arcade drive code and it had been driving perfectly. It only stopped working once I updated the robot, which makes me think that something is either set up wrong or there is a huge bug in the updates, and that it is not that the roborio is broken.

The Roborio lights are all good except the COMM light is red, which means that there is no code on the roborio despite me “successfully” deploying code to it… When I deploy code, the COMM light goes away, and it only turns red when I try to connect it to the Driver Station. Upon further investigation I have noticed that the COMM light is only red when connected to the driver station, and otherwise is fine.

Here is the code I am using. I haven’t done a thing to it since I just downloaded it from wpilib.

#include “WPILib.h”


  • This is a demo program showing the use of the RobotDrive class.
  • The SampleRobot class is the base of a robot application that will automatically call your
  • Autonomous and OperatorControl methods at the right time as controlled by the switches on
  • the driver station or the field controls.
  • WARNING: While it may look like a good choice to use for your code if you’re inexperienced,
  • don’t. Unless you know what you are doing, complex code will be much more difficult under
  • this system. Use IterativeRobot or Command-Based instead if you’re new.
    class Robot: public SampleRobot
    RobotDrive myRobot; // robot drive system
    Joystick stick; // only joystick

Robot() :
myRobot(0, 1), // initialize the RobotDrive to use motor controllers on ports 0 and 1


  • Runs the motors with arcade steering.
    void OperatorControl()
    while (IsOperatorControl() && IsEnabled())
    myRobot.ArcadeDrive(stick); // drive with arcade style (use right stick)
    Wait(0.005); // wait for a motor update time



Any ideas on what to do?

Can you try the following…
[1] Make sure a gamepad is connected and wired to slot 5 (the last spot) in the driver station. Change your source to use that slot, or just use an extra joystick/gamepad to ensure that slot is not empty. Either is fine.
[2] Then restart your project using the restart-robot-code, or redeploying.

Does that remove the crash symptom?

I also had this issue. FRC has released an update for Eclipse on 1/15/2016 that fix this issue for me. Try updating your Eclipse plugin.

Can confirm that updating Eclipse worked for us too in fixing this issue.