"No Robot Code" problem

Hi, I am programming on C++ in WindRiver. Until a week ago everything worked fine and my code worked well, about a week ago i started getting the “No Robot Code” message on the Driver Station. I then started trying to find the problem, after about an hour it suddenly started working again. The strange thing is that i didn’t change a thing… it was the exact code that didnt work before. The problem is that now I updated the workbench to 4.1 and since then keep getting the “No Robot Code” problem. I even tried downloading the original SimpleRobot template untouched but still, “No Robot Code”. There are no errors undeploying or downloading code, and yet the code doesn’t run.

I will be thankful for every advice.

This might be a problem with the system resetting itself. After updatung did you change the prefrences to download the correct “.out” file?

Look at another post by me in “code doesn’t load” solution.

its a video link that should be used with the FRCprogramming guide if what I said above is your problem.(I think it is because you said you switched code)

A number of people had an issue with 4.1. When using the DriverStationLCD class, the code would not load and an error about a symbol would be displayed on the serial console.

If the above is the case, then 4.2 fixes the DriverStationLCD issues, but are now having a similar issue if using the AxisCamera class. When removing this class now, our code works.

If you are using net console or can connect a serial cable to the cRio and connect via a terminal emulator, there is loads of useful information that will be displayed.


I changed to the right .out file each time… it didnt help.
after re-imaging the crio my code came back to life again, and a while after updating to 4.2 it stopped working again… same error.
i tried re-imaging the crio again, but this time it didnt work… what do i do?


Scroll down to the NetConsole instructions. Install it and post what errors show up on the console