No Robot Code

I’m having a problem getting code on the robot. We’re able to undeploy and download the code using wind river, but when we reboot it shows a red light next to robot code. I’m not sure why it’s doing it, I’m able to connect to and ping the robot controller.
For some reason, this works on one of the laptops, but not others. Any one have any ideas?

this is the exact same problem I’m having right now. Windriver seems to download to cRIO fine, but the ‘robot code’ light stays red.

Did you see this thread?

The Driver Station is updated, I did the labview updates, but It still reports that there is no robot code.

I tried the ‘run code at start up’ thing that was in a doc file in the link jalburty gave, and I got it to work. Is there a similar thing for c++ though? because thats only labview. Is there a way to ‘run code at start up’ using windriver? Also, for some reason the voltage does not show, so I need to fix that as well. Thanks

I would confirm that you have the LabView default code running correctly by completely going through Chapter 2 of the 2010 FRC Control System Manual before moving on to C++. Do the joysticks work in both tethered and wireless configurations?
Here is where to find the manual:

Please keep us posted as to your progress.

OK, I got it working, but in a different way. For somereason, the FIRST downloader in Windriver shows that it is uploading code to the cRIO, and gives no error, I looked into the cRIO through ftp, and saw that it had no code (it did not have the ‘system/startup/…’ directory). So All I did was created the folders and put the binary file in there manually and it worked. Anybody have a thought why the downloader was not working, or was I doing something wrong?

We had the same problem earlier today, and our solution was this: create a new project in WindRiver, and copy your old project over one file at a time. After each file, rebuild the project and redeploy it to the robot. When you find out exactly which file is giving you the problem while running, debug it and figure out exactly what’s wrong with the file. It might not be the specific solution to your problem, but it might help you figure out your solution, or at least rule out a few things. Good luck!