No Robot Code

When we try to deploy our robot code, it says “Build Successful”. In the FRC Driver Station, however, says there is no robot code.

-Communication light is Red on the roborio and the driver station

Code can be found:

Build Log:

Buildfile: C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\build.xml
Trying to override old definition of task classloader
clean:
[delete] Deleting directory C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\build
[delete] Deleting directory C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\dist
compile:
[mkdir] Created dir: C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\build
[echo] [athena-compile] Compiling src with classpath=C:\Users\Robotics1/wpilib/java/current/lib/WPILib.jar:C:\Users\Robotics1/wpilib/java/current/lib/NetworkTables.jar: to build
[javac] Compiling 7 source files to C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\build
jar:
[echo] [athena-jar] Making jar dist/FRCUserProgram.jar.
[mkdir] Created dir: C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\dist
[mkdir] Created dir: C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\build\jars
[echo] [athena-jar] Copying jars from C:\Users\Robotics1/wpilib/java/current/lib/WPILib.jar:C:\Users\Robotics1/wpilib/java/current/lib/NetworkTables.jar: to build/jars.
[copy] Copying 2 files to C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\build\jars
[jar] Building jar: C:\Users\Robotics1\Documents\FRCRobotics\2015-16\BasketBall\dist\FRCUserProgram.jar
get-target-ip:
[echo] Trying Target: roboRIO-5243-FRC.local
[echo] roboRIO found via mDNS
dependencies:
[echo] roboRIO image version validated
[echo] Checking for JRE. If this fails install the JRE using these instructions: https://wpilib.screenstepslive.com/s/4485/m/13503/l/288822-installing-java-8-on-the-roborio-using-the-frc-roborio-java-installer-java-only
[sshexec] Connecting to roboRIO-5243-FRC.local:22
[sshexec] cmd : test -d /usr/local/frc/JRE
deploy:
[echo] [athena-deploy] Copying code over.
[scp] Connecting to roboRIO-5243-FRC.local:22
[scp] done.
[sshexec] Connecting to roboRIO-5243-FRC.local:22
[sshexec] cmd : killall -q netconsole-host || :
[scp] Connecting to roboRIO-5243-FRC.local:22
[scp] done.
[echo] [athena-deploy] Starting program.
[sshexec] Connecting to roboRIO-5243-FRC.local:22
[sshexec] cmd : . /etc/profile.d/natinst-path.sh; /usr/local/frc/bin/frcKillRobot.sh -t -r;
[sshexec] Connecting to roboRIO-5243-FRC.local:22
[sshexec] cmd : sync
BUILD SUCCESSFUL
Total time: 9 seconds

Things we have tried:
–Updating Roborio firmware
–Tried with multiple roborios
–Tried with last year’s code (worked last year, also included more sensor code, no change)
–Tried redeploying easily 10 times

After reading Ozrien’s post in https://www.chiefdelphi.com/forums/showthread.php?threadid=141652
–we tried to put a joystick in our last port (and in both ports). Did nothing.

Have you tried looking for any messages that appear when attempting to run the code manually over ssh?

Just checking given all the things you did list that you’ve tried…

If you reimaged the RoboRIO, did you reinstall the Java Runtime on the RoboRIO?

2 Likes

I also had this happen to me. Here is a link to the thread.

One thing I found(I believe it works) is to start over with the code. Deploy a basic FRC WPILIB example and to add one piece at a time and find where the code errors out.

Looks like eclipse is able to connect but not the driver station. Double check that your team number is correct in eclipse preferences > WPILib (if not, fix it and redeploy) and that the team number is also correct on the driver station.

Are you sure you are running to code in github? There are 9 source files in github, but your build log only shows 7.

Found the issue.
The Shoot command activates the solenoid subsystem, waits 5 seconds, and then deactivates it. The issue?

We put
private SolenoidSubsystem SS = new SolenoidSubsystem(); as the attribute, instead of leaving it
private SolenoidSubsystem SS;

and then initializing it in the initialize method.

That doesn’t explain why the communication light was red. Are you sure you didn’t mean the robot code light when you said that in your original post?