No robot communication

Hi, I have recently preformed a roborio recovery to be able to udate the firmware and the roborio image. Currently me and my team have hooked up to the roborio a radio, CAN devices and an RSL. The radio’s WiFi siganl appears on our laptop however when I connect to it and open the driver station application, the robot communication indicator is red.

capture

when I try pinging the gateway address using CMD it reads:
Pinging 10.46.61.1 with 32 bytes of data:
Request timed out.
Any idea on what could be the problem?
Thanks in advance.

Have you setup the radio using the FRC radio tool?
Look at the Driver Station app tab for diagnostics too. It’ll have more information.

no, do you think you can guide me?

This is the page you’ll need to find out all about setting up your control system: https://docs.wpilib.org/en/latest/

In particular:

Are you wired to the roborio over usb or Ethernet or are you trying to connect to the radio. Is the radio programmed? If not use the FRC Radio Programming tool, tons of documentation that can help out! Make sure you flash the firmware first!

my setup is like this: I connected the PC to the radio directly through an ethernet cable, when I press configure it produces an error:

@djp0915 im not sure if it is programmed, I tried connecting over WiFi.

Hmm, you could do a few things to prevent this. Turn off WIFI connections, disable firewall. As for the radio make sure it is plugged into the port closest to the power jack. In the software when it first loads make sure it’s on LAN, enter your teams info then click Load Firmware. After click configure and make sure it is set to OpenMesh.

Ok thanks, I will try.

@djp0915 I disabled the wifi adapter and on startup of the FRC radio configuration utility I set it to “Ethernet”, I entered our team info, but when I pressed Load Firmware it gives me this error:

Well, keep the adapter enabled. Turn WiFi connections off and not the adapter. Click the WiFi symbol on the bottom and click WiFi.

Have you downloaded the new FRC Update Suite for 2020? It has an update for the driver station that may fix your issue.

1 Like

Update: I sat for a long while on this problem, eventually I noticed that the Driver Station is searching for a specific ip address to communicate with the roboRIO. After SSHing into the roboRIO and using the command “ifconfig”, I saw that the ip assign to the roboRIO was different then the one expected by the driver station, so by using the command “ifconfig eth0 10.TE.AM.2 netmask 255.255.255.0 up” I’ve managed to change the ip to the expected 10.TE.AM.2 which allowed me to establish robot communication.

The RoboRIO defaults to DHCP. The web dashboard lets you change the IP to static. If you don’t know the Ethernet IP, connecting via USB works to get into the web dashboard to change the Ethernet IP (the USB interface IP when the Rio is on USB is 172.22.11.2). It sounds like the underlying cause is that mDNS is not working for you; setting the Rio IP to 10.TE.AM.2 is a workaround.