Not Moving following "Getting Started to 2012 Control System"

Hello Everybody, we are a rookie theme and we were following the guide:

http://www.usfirst.org/sites/default/files/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2012_Assets/Getting%20Started%20with%20the%202012%20FRC%20Control%20System_2.pdf

… A couple of weeks ago, everything worked, we could move the robot as indicated with the guide… but after that, we tried to make another test (Without changing the code) and it didnt work… in the Driver Station it said “No Robot Program”… we could manage to solve that issue… We dont know exactly how… but the led is now green… But now we have another issue… It doesnt do anything!!!.. In the driver station, we can see that the leds from the joystics receive input (when we click a button, not we whe move the joystic)… and there is not any warning or message when downloading the program in LabView… We have search on the threads but nothing…

Additional information… the jaguars keep blinking yellow… they never go into a solid yellow led. We are working on the remote mode, if we go to automatic there is an error on the message window “Error 44061”… We havent change the code a thing, so we dont think it is the program, and as it has already worked one time, so we dont know if it is with the connections… Please, someone can help? we are very close to the competition and we havent been able to make our program!

Thank you very much!!!

Please let me know if you need some additional information.

Assuming you are using Labview, try tethering the robot with the programming laptop and downloading the code by clicking the arrow button. Open the driver station and enable the robot after the code has downloaded. Wait around 5 seconds and try moving your drive joystick, that should work. Let me know if it doesn’t.

Post the entire error log here. It sounds like either a Motor Reference issue (the speed controllers will blink if there weren’t created correctly in the Begin.vi) or a Camera issue (if the camera isn’t connected and/or isn’t communicating to the cRIO it will error out repeatedly and can cause this kind of behaviour, unless you have ALL the camera code disabled or removed).

My bet is that the camera is indeed hooked up but was reset accidentally (by something pressing the reset button) or it was configured but lost it’s configuration due do the last version of the Camera Config Tool which would make it factory reset on a power cycle. If you do have a camera and the light is green this is not a problem. You should also be able to ping the camera at 10.xx.yy.11

You can get an error description under Help -> Explain Error
An error -44061 means:

FRC: The loop that contains RobotDrive is not running fast enough. This error can occur if the loop contains too much code, or if one or more other loops are starving the RobotDrive loop.

That usually means the Teleop loop is taking way too long to execute and your motors have been automatically shutdown as a safety precaution.
The Jaguars will start blinking at that point.
Is your Teleop the default one or has it been modified?

In any case, an easy check to make is to create a brand new project under another name, Build and Run as startup .
That will isolate the problem as a code error or a hardware problem.

Thank you guys. Will check your recommendations today and see what’s the problem. We have not the camera connected so that could be the issue, and we were trying this with a brand new program.