Nothing Works!

Our bot does not do ANYTHING right. :eek: It was working fine last night, just not anymore. The camera has erratic and random spasms, even without code running on the camera, the tank drive does not respond to joysticks, and the light sensors do not detect. Everything in the sidecar fails us. However, relays work.

Here is what we have done to try to fix or diagnose the problem…

-replaced sidecar

-replaced PWM cables

-probed for inputs

-went back to old working code

-tried relays

-re-imaged cRIO

-replaced big gray cable

-tried sample code which failed

Does anyone have any ideas? Any input would be nice.


EDIT: We unplugged everything but two speed controllers/motors and they worked for some reason while using sample code.

The first thing i would do is check to see if there are all 3 lights on the sidecar. If a wire is loose to power it, it may do that to you. The other thing i would do is plug in a fairly long ethernet cable from your driver station to port 1 of your cRIO. If it works connecting to that, i would check for network problems between the router and bridge.

Fully charged battery?

the battery?

beat me to it.

Bingo on the battery.
I have also seen a non-isolated cRio do crazy things like that.

Our programmer was having issues of our camera the other day and I recommended that he re-format the camera or reset it to factory settings, and that worked. Just a thought.

Can you explain what this means? Did it not load? Did you get Robot Code on your Driver Station? Did it enable? What error messages do you get on the Driver Station Diagnostics box?

To me this indicates that you have a short between 5V and GND on one of the PWM cables you unplugged from the Sidecar. If this is true, with everything plugged in, I would think that the 5V light on your Sidecar would not turn on.

There are no warnings on our bot or error messages, just random stuff going on.

We tried sample code given by FIRST and ran it on the robot.

For some reason, everything works now, but we do not understand why.

Thanks for all the help everyone!

I echo the battery posts… (no pun intended)
Make sure you have a fully charged battery that has all cells working.

I have seen really funny things happen with batteries with a bad cell…

You need to check the voltage under load to determine whether it is good or not…