Nvidia Jetson TX1 fullscreen camera issues

I ran this pipline:

gst-launch-1.0 nvcamerasrc ! ‘video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080,format=(string)I420, framerate=(fraction)30/1’ ! nvtee ! nvoverlaysink -e
Into the terminal of the TX1 and it somewhat worked, apart from the displayed picture being inverted. However now the screen wont close, I’ve tried multiple commands I found online to try to minimize the full screen, or just bring forward the terminal, but it does not seem to do anything. This is my first time working with a jetson and Im quite new with Ubuntus syntax.

If you’re really stuck then pull power and reboot it.

Ctrl+C should kill it but you probably lost focus on the Terminal so that won’t work. You can try Alt+F4 or Ctrl+F4 as well. Failing that. You can try Ctrl+Alt+F1 and then login and try to kill the gstreamer process and then switch back to X with Ctrl+Alt+F7.

You’re reading the video from the sensor in “format=(string)I420” from the sensor and then you forward the stream directly onto the RGB screen without any conversion. I420 (or YUV) and RGB are two different color spaces. So the “somewhat inverted” picture is expected.