OM5P-AN Flashing Timeout

Every time I try to flash the new radio (using FIRST’s utility), I get the error message “Bridge firmware load failed: Timeout flashing radio.” It’s able to detect when I power-cycle the radio, and begins to flash, but then just times out and never finishes. Firewall is disabled and the program is run as administrator. Anyone have any ideas?

The KOP radio should already have the right firmware.

Have you tried these instructions for flashing the firmware?

Are you sure that’s the same firmware as the FIRST firmware?

No, but Andymark is pretty good about those things. It is a link from the Andymark Webpage for the Radio. We will be flashing the radios this evening. I’ll let you know if it works.

The instructions on the AndyMark page are for non-FRC use applications.

For FRC, you’ll want to follow the directions here:
Programming for Home Use for FRC

The andymark instructions worked for me. We could not get the frc configutation tool to work.

I was getting the same error.
I then tried to use the flash tool under the:
C:\Program Files (x86)\FRC Radio Configuration Utility
which worked for others. Except, the unit for 2017 is OM5P-AC
but the firmware didn’t work and I received this error:
is of type ‘OM5P-AC’ that we have no image for

I then followed this -

In my case, step 2 and 4 did the trick for me.
Note, I have the NI Suite installed on my Win10 Surface Book.