Omio Computer

Now that I have purchased an assembled the Omio x8, I’m experiencing troubles with Mach 3 not working. Our district purchased new computers this summer for my classrooms and they are pretty high end due to running SolidWorks on them.

Has anyone that has an Omio been able to run Mach 3 on a windows 10 64 bit computer with a USB 3.0?

I’m seeing posts on various other sites that say it should work.

Thank you!

I was unsuccessful in connecting my windows 10 computer to my OMIO X8 over usb 3.0. As a workaround, I have been using a 32bit Windows 7 Virtual Machine running on VMWare Workstation with Mach 3. I connected the OMIO to a usb 2.0 port on my computer and made sure that I had a USB 2.0 connection in the VM settings. I hope this helps.

I got my laptop running Windows 10 with a USB 2.0 port to work with the Omio controller. Nothing special, but I specifically never tried to use USB 3.0.

For our permanent install, I use an old desktop with Windows 7 and USB 2.0 and it works great. Maybe reach out to your IT department and look for an old computer to use as a dedicated CNC controller.

I second the “recycle old Win 7 PC” approach. Using an old Win 7 laptop dedicated to the task and it works fine.

We’re using one of the many Atom based Windows 10 mini-PCs with USB 3.0 and haven’t had any issues.

I’ve run Windows 10 with USB 2.0 as well with no issues.

Can you describe what’s not working in mach 3 in more detail? Can you not install mach 3? or open mach 3? or does mach 3 open up but it is not communicating with your omio? Or is communicating but you can’t make the omio move?

I’m running Windows 10 with USB 2.0 on mine, but 3.0 shouldn’t be any different.
Describe what’s wrong. Did you follow the Omio instructions to the letter?

So the install went fine and I believe the program opens up fine. When I use the arrow keys on the computer, the numbers change in Mach 3 but nothing moves on the router.

Maybe I’m just missing some steps to connect it to the router.

Are there steps that I’m completely overlooking or not following? I was working through the manual that they sent via email.


When you purchased the omio they should have emailed you (or whoever bought it) instructions on the install process of mach3. The instructions are in broken english, but were not that bad to follow. I’ll PM you the link.

I received that, but after going through the step where you use the arrow keys to move, the router doesn’t move. Am I correct to say that it should move?

The Omio website explictly states to use USB 2.0 and not use USB 3.0

1 Like

I had the same issue when I first got mine but was solved by restarting windows, plugging in the USB and then launching mach 3. I use a laptop with windows 10 but it is pre USB 3.

Do the reset and home buttons on the controller do anything?

I have communication with the router now. My tech person and I redid steps 3 and 4 in the setup and it now works. Not sure what was messed up along the way the first time.

So I am using a Win10 64bit with 3.0 usb machine. The 32 bit and 2.0 usb is old requirements according to the company.

Hopefully everything else works correctly!

1506 was running an old Win XP machine for the x8. It seems to work great with the router, but you have to use smaller thumb drives to move files from the design computers.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.