OMIO Router Setup and Operation help

A number of teams are either using or setting up OMIO routers. This thread is a place for people to share information and advice as well as ask questions related to the router.

I’m in the new purchaser setup group and here is my question. I’m having intermittent issues with USB connectivity. I read in the CNC Rourters for FRC Robotics thread that others have had this problem and were able to address the issue by grounding the VFD to the earth ground on the input connection. I tried this and when I plug in the controller the power connector arcs from the earth ground the controller frame.

It’s not clear what damage, if any, this has caused.

Here are pictures of the connection, blue wire. Is there any advice on why this is occurring, how I can fix and how to determine if I have damaged the VFD.

Pictures with wire.

1 Like

When we did this mod we also grounded the case to that leg in the controller.

On the machine side, we grounded the machine itself and the spindle (Wire fed through the existing cable trays) to the ground leg of a screw clamp 110V connector plugged into the same power strips as the controller. This is definitely not the “correct” way to do this… but it worked during a quick troubleshooting session and we haven’t revisited it since.

Thanks. A couple of questions.

First, I got down this path because Mach3 is showing USB communication errors. Was this the same initial symptom for you?

Can you confirm the current connection is correct. It doesn’t make any sense to me how either of these points could have sufficient voltage to arc.

I will look into grounding the router as well, but this doesn’t seem like it would be contributing to my issue.

Thanks for starting this as we are also new with this machine. While we have not experienced your issue we did have several installation issues with getting the Mach3 software to load the various plugins in the correct directory. We initially tried to use a Windows 7 64 bit computer and when that did not work we moved to a Windows XP 32 bit setup that also did not work until we discovered the directory issue. My question is has anyone been successful in using a Windows 7 or 10 64 bit setup?.

I have an OMIO X-6m, out of the box, and can’t seem to get the machine and Mach3 to talk. I am using a 32 bit windows pc, an evaluation copy of Mach3 but when I try to control the CNC from Mach3 there is nothing.

When I turn on power I can manually control the spindle when I take it out of Mach3 control-- this I learned from another youtube post.

The CNC router is Chinese of course and I am playing 20 questions with a 12 hour delay.

Any suggestions on troubleshooting?


I think you should try for provided version of mach3 and installing their USB driver.

Thank you and have installed the software version from the manufacturer previously and motors don’t turn.

Did you also install (and configure mach 3 to use) their USB driver?

You need to provide more information for us to be helpful.

What are you trying to do in mach 3?
What responses do you get?
Does the “DRO” in mach 3 increment as you try to jog the machine, or stay fixed?
Are you able to see the limit switches trigger in mach 3 when you hit them manually?

There are a few different manuals from mach 3 that are fairly good for figuring this stuff out.

Thanks and appreciate the help. The manufacturer sent files to install and overwrite in the installation directory which I did. Instructions said nothing of USB driver.

At this point I just want Mach3 to talk to the machine. The only feedback I get is the motors lock when I turn on the CNC controller-- other than that I can’t use the PC to move any of the motors at all.

Sounds like you need the USB driver from Omio then.

the same email they sent us with Mach 3 and the setup instructions had it, double check that and then I guess ask omio to send the driver.

Thanks Chief!

You were right and the USB driver was in their files they sent. I had put all the files in the Mach3 folder and simply moved the .dll files to the plugins folder inside Mach3. She spun up and moved.

Next is the run a test file to see how it runs.

Thank you!

Steve Dawson

Can anyone send me the configuration files that are sent with the machine? Someone within our school district placed the order and they have not passed on the emails they received with those files. I am looking for the USB driver and any configuration for MACH 3. We have the OMIO X8-2200-USB.
Thank you!

1 Like

Please download below links for your X8-2200L machine.

1, Software , Manual & setting files link for X8-2200L-USB:

After download zip file, unzip it , then please see the “Mach3-ConfigurationV3.pdf” first , follow the instructions step by step.

2, Wireless control handle instructions link

3, Please refer to this video for the assembly machine.


needing help with spindle on new X8-2200. It is for a school

What is wrong with it?

Can you be more specific? Thanks!

So I am having a problem with X8-2200 at our school we are doing the initial setup and I have ran into a spindle problem. So if I can get some help to find out if I need a new spindle. When I try and due the initial test run as the manual says M3 S5000 the spindle with start and the VFD on control box will read up to around 70 and then will give ERR13 code and spindle stops