On compile: "Coff file format for 'ifi_library.o' is out of date."

I read this:
http://www.chiefdelphi.com/forums/showthread.php?t=40036&highlight=ifi_library.o

Though they get the same error it does not seem to address my issue. When ever I try to compile I get this error:

MPLINK 4.02, Linker
Copyright (c) 2006 Microchip Technology Inc.
Error - Coff file format for 'ifi_library.o' is out of date.
Error - Could not build member 'ifi_library.o' in library file 'C:\Documents and Settings\Erik\Desktop\TRC Code\FRC_library.lib'.

I am using versions:

  • MPLAB IDE v7.30
  • MPLAB c18 v3.02

I am sorry if this is answered in the post above but I did not understand it if it did. As you may guess I am not a programer myself, I am setting up the laptop for the porgraming team for regionals.

These are all apps that I have downloaded of the net, so maybe I need something that FIRST gave me, though I am not sure.

Any help is appreciated.

You should be using:

MPLab v7.2
C18 v2.4

Newer version aren’t supported.

I will just note that MPLab v7.21 has not given me any problems. It really doesn’t add any functionality, but it’s what I have been using.

The big problem is the compiler, it uses a different binary format for the compiled files in the 3.0 version, whereas the IFI precompiled libraries are built in the old format, so they’re not compatible. I don’t see why they couldn’t include backwards compatibility, it’s not a huge issue but I like to be up to date.

There’s more than that…

My problem is our team is limited on the computers we have to develop software. I am one of the mentors and bring my laptop from work in for our team to use in the evenings. For work I use the MPLAB IDE v7.31 and the MPLAB c18 v3.06. The only way to use the current IFI/USFirst library is to unload my office version of MPLAB/C18 and reload the older software.

Can IFI/USFirst build a library for those users that have the new Microchip MPLAB.

David Barr
Mentor (Programming)
Team 141 WOBOT West Ottawa High School

I dont think they will. I havent tried but it might be possible to have 2 folders. One for each version of c18 and run MPlab and change the default folder it looks for the files in. I havent tried this though.

would it work to create another account (probably administrator) and instal the robotics stuff there?

Matt,

The issue is a PIC issue and not an IFI issue…

From the readme file of C18 compiler V3.00:


  1. Important MPLINK and MPLAB IDE Compatibility Note

Due to a change in COFF file format, MPLAB C18 v3.00 and later will
not be compatible with versions of MPLINK prior to v4.00 or
versions of the MPLAB IDE prior to v7.21.
MPLAB C18 v3.00 and later will have backward compatibility to earlier
versions at the source level only. Any existing object files or
libraries compiled with earlier versions of the tools will not link
using new versions of the tools. They will need to be recompiled
from source.
This change was required for support of new products introduced by Microchip a few years ago.

I had hoped that IFI would offer recompiled libraries but they have not. I would guess it might have something to do with over 1300 teams getting free C18 compiler software from Microchip.

Regards,

Mike

From my store of “usefull things to remember”.

I once read that the MPLAB compiler cannot handle the linking of files whose source path exceeds 62 characters. (Didn’t count the length of your path)

But almost anything in the C:… user … docs folder stream if you’ve organized it would be banging hard on the limits.

Simple solution == move your source directory closer to C:\

ie c:\FirstCode\XYZ

…just a heads up that this thread was originally posted during the 2006 season – so the applicability of some or all of this information may (or may not) have changed.

The initial thread issue remains the same today re path length.

the other issues also remain as far as using MPLab v7.2 and C18 v2.4.

The decisions about library updates are what they are though.