Only one joystick works when two connected

We are trying to use two joysticks. they both show up on the drive station and if you activate anything on the joysticks the appropriate one will turn blue. In lab view we have usb1 associated with joystick 1 and usb 2 associated with joystick 2. no matter what we do only joystick one will work. if we reorder then on the driver station the control moves from one joystick to the other but only joystick 1 will work in labview. We’ve scoured he code looking for some inappropriate reference to joystick 2 that could be causing the error but we’re stuck. Not sure what else to try. Any suggestion would be greatly appreciated.

Check the Diagnostic tab for related error messages about joysticks or refnums.

Check the name given in Begin is exactly the same in Teleop where you are using it.
Better yet, copy the text box from Begin and paste it into Teleop and wire that in.

We’ll give that a try and let you know how it worked out. thank you.

We tried copy the joystick references form begin and using them in teliop with out sucess. still did not work. when looking at the operators console we have no error messages for refnums or joysticks. Puzzling.

I think its the setup tab on the DS, IIRC, that has the joysticks connected to the computer. Check to see if they are listed and if they are in the correct slots 1 and 2.

If you want to attach your vi’s for Begin & Teleop we can check them out.