OpenMesh Radio

We are trying to configure our OpenMesh radio, and have run into many different error codes. The first error code that occurs is when we try to load firmware to the radio. The code says “Bridge firmware load failed: Error finding NPF device name for adapter: ASIX AX88772C USB2.0 to Fast Ethernet Adapter Try disabling all other adapters. Please reset the bridge and try again.” We disabled all other adapters, but do not know how to reset the bridge.

If we try to configure the radio it gives an error saying “Bridge configuration failed. Firmware too old. Press OK to close open dialogs, then load new firmware.”

We have been in this loop for a few hours now…

Resetting the bridge is done by cycling the power.

Have you tried using a different PC?

We have unplugged the radio and plugged it back in if that is what you mean by cycling the power.

And we have tried doing this on three different laptops.

Well, you can try manually loading the firmware…

This assumes that you have installed the FIRST Radio Configuration Utility already (which you have).

First, disable all network connections other than the Ethernet you are going to connect to the radio.

Step 1. a. iscd c:\Program Files(x86)\FRC Radio Configuration Utility
(this might be easier to do one directory at a time, e.g., cd c:\Program Files(x86) followed by cd FRC Radio Configuration UtilityStep 2. d. isap51-flash.exe {INTERFACE#} firmwareOM5PAC.bin
This assumes you have the OM5P-AC. If you have the older AN version, then change AC in Step 2. d. to AN

BTW, if Step 2. b. gives you more than a single choice, then your problem was that you didn’t actually Disable the other network adapters.

OM5P_Manual_Setup.pdf (72.9 KB)

The instructions say to download certain files. Do you have a link to those files?

Those files are already installed by the Radio Configuration Tool, so you don’t need to download anything else.