Operator Interface, Need help.

We are having problems with our OI, we plugged it in last night and only hte power light came on, none of the others did.

Weve had it working before.

Any ideas?

Make sure everything is wired properly
And Make sure you set the channels

Thats about all the advice i can offer

But its better than nothing

Brian Team 56

Jordan, in case you don’t read my email first, I think you should talk to Innovation First, on the phone during Texas business hours, at the phone number (903) 474-… that is on the control system manual. This malfunction sounds like a microcomputer failure.

Plugging in the Wall Wart power supply to the OI, with no cables connected turns on the power light, and the digits start showing PO5, PO4, … which is the power-on self-test.

A blown F1 fuse lights the Led for F1 on the front panel; the four fuses have their own lights.

Anyone else tried theirs?


I agree with Lloyd Burns, Sounds like a catastrophic failure. If you have everything unplugged but the power supply, it should come up and run through self test.
Possible failures: Even though there are lights to indicate fuse failure, use an ohm meter to check continuity anyway, certain power detection schemes can be fooled if EVERY fuse is out.
(But I doubt this, the system is very well thought out).
Really weird possibility, … the little “reset oi” button may be sticking or broken.
Like Lloyd said, calling Innovation First is the best idea.

My two cents

Steve Alaniz

make sure the device is warm… we had a problem last year (on the robot side of the controls) where if our board was too cold, it would nto start. This happened to us both in hartford, and in florida (the air conditioning in the tents was too much for it)


I had this problem happen to me once. I accidently plugged the wrong type of power supply into the controller. I forget if the interface takes AC or DC, but I plugged in the opposite and only the power light came on. Good thing no damage was done.

Random thought-

Try tethering it to the Robot Controller, while supplying 12v from the battery to the robot controller. See if anything more powers up. If team number settings are right, that should provide at least something for it to run off of.

Marc, we actually tried that. No luck.

Lloyd, I did get your e-mail and I will be calling innovation first tommorow.

One of our mentors is an electrical engineer and he said its nothing weve done (which is good).

Try just connecting the tether and see if it powers up with the robot interface. If not, double check that the “reset” button is not damaged or otherwise held down somehow. If you have another tether cable try that as well. Let us know what you find.

I know that the reset buttons (or any button for that matter) are not messed up.

I will try powering it by the tether tommorow.

Hopefully I can figure it out with a call to IF

I called today, and while I was on the phone the OI started working agian. So I got off the phone

Then from there it stopped working, we messed around the the next half hour and it only seemed to work if you left it for a while. So I called IF back and am RMA’ing it.

Kinda sucks that we have to wait for it back now, but hey better than none at all.

Yep, I had to send our robot radio back to InnovationFirst so I know how you feel, but the good thing is, it’s giving you trouble now instead of in the middle of competition…

Best Luck!

Steve Alaniz

“What good is technology if you can’t abuse it?” - Ted Forth

Got this e-mail from IF today (not complete for security reasons):

Listed below are our actions and findings on the unit that you sent to us on a RMA.

We did find a manufactures defect with the unit. We have repaired your unit at no charge. Therefore, total repair is $0.

Looks like everything will work out. I have to say that I am UNBELIEVABLY impressed with Innovation First, there products seem rock solid and in the off chance they do mess up they are great about fixing them.

Thanks for all the advice guys.