Our Crio Won't Run deployed Code and there are no Error messages

Are you pressing the green enable button? The status indicator should read “Teleoperated Enabled” in the driver station after you push the button.

When you try to drive, do you notice if the lights on the Jaguars are doing anything? I believe when they’re receiving a neutral PWM signal they’re solid orange, and then they flash green and red depending on which direction you’re driving them. This is based on my (somewhat quirky) memory and CAN mode, so I’m not 100% sure. What are your Jags doing?

Matt

Remember to change your battery constantly… If it drops below 11V, it sometimes does not respond.

After we enable it, it syas teleop enabled and the jaguars lights keep flashing yellow like they are on standby. Our battery voltage is just above 12v

Flashing yellow like that indicates no signal I believe. Re-check all of your PWM cables for proper orientation and a snug fit. Otherwise it sounds like your robot is up and running.

Except that it’s not working, all of our pwm’s are connected properly and our robot should be working but it isn’t, thanks for your time guys

Could be code and could be electrical.

Take a photo of the Digital Sidecar, so we can see what’s connected where.

I don’t remember if the basic default code actually does anything.

It may also be worth connecting a servo motor (any standard servo will do) to the sidecar and putting the 6V jumper in place to power it, and just seeing if it reacts at all to your joystick inputs.

Just to clarify, the servo should connect to one of the PWM outputs you’re trying to drive a Jaguar with, just to clarify a valid signal is being generated.

Matt

If you’re going to be working in the shop with your robot this evening, and you have available internet near the robot, PM me tonight, I can do a live troubleshooting session with you via Skype or some other system.

sry i couldn’t do that but i can give you our robotiocs schedule if you want to try again

we do saturdays 9am-3pm eastern time
and weekdays from 3:30 pm-6:30 except sometimes we leave by 5:30

Thanks a lot

We just ran into a similar problem…we were going to practice a bit with our “junkyard” bot - altho it has legit cRio, digital sidecar, power distribution, we use Victors instead of Jags, and of course some spikes.
Anyway, the code will deploy, and we can ping all the way to the cRio, moreover, the drivers station reports green lights for communications, robot code, etc, but we get nothing - I mean nothing, when we try to drive. Not one button or joystick axis will respond. Ironically, we get video from the camera, again indicating communications are good. We have reimaged, redeployed several times, but nothing. It is almost like the digital sidecar is not working or we have ALLL the wires wrong, since nothing will work. This has befuddled us for two nights, and is getting a bit frustrating. Help would be appreciated! Thanks, Chuck.

have you tried looking at your target consul? errors that don’t show up in compilation because they are not syntax errors will appear there (ex. code with the gyro not on analog 1 will compile because the syntax is correct, but will not operate because it is not on analog 1).
if you are 100% sure that you connected all of your pwm’s correctly on both ends and have declared all of your motor controllers correctly, then they are not receiving a signal from the side-car which could electrically be (based on previous info):

  1. Bad C-Rio Card
  2. Bad Side-Car Cable
  3. Bad Side-Car
  4. Bad Motor Controllers
    the best way to try to determine which it is, is to replace each individually to see which is the problem… a very expensive problem if you don’t have backups…

First the obvious potential error - is the DIO module in slot 4?
Are you getting any errors in the message window in the Diagnostic Tab?
Do the LEDs on the Victors change from blinking to solid when you enable?
If you are using LV, when you probe the joystick functions, are you getting correct readings?

I’ve got another direction to look, as well.

Test your driver controls.

Go to the Driver Station Setup tab and check to see that your USB devices are all listed on the right.

Push a button on each of your joysticks one-at-a-time and the corresponding USB input should light up blue.
If you’re using the Cypress, that entry may already be blue if one of your switches is normally closed.

We see a lot of this type of behavior (lack of controls) when a bunch of stuff is plugged into a single USB hub and it isn’t getting the power it needs to run everything.

You may also want to check your code and see if the number that you’ve set for the jaguars/victors to connect into the sidecar are connected properly.

If you have stated that the drives should be connected to port 1 in the code, then connect it into port 1 of the PWM side of the sidecar. I made a mistake like this once.

Hope it helps.

What is the Robot Status Light doing? If the robot is enabled in Teleop, it should be on with a brief wink off every second or two.

Hi. I’ve been browsing around the forums and I noticed this thread. Our problem is very similar to this, with some minor differences. We have built and deployed a code for doing multiple things (using C++), and it has deployed fine with no error codes, no indication that anything was wrong. However, we noticed that our alterations to the code do absolutely nothing. We essentially commented out almost the entire code, built and deployed it, and yet it still ran (ex: we commented out our joystick control [2 joys, tank drive setup] and yet when moving the joysticks the robot still drove even when there was no drive built in). All our PWM connections look fine and react perfectly normal, it just seems like the code we’re deploying to the robot simply isn’t being implemented. Thoughts?

You are pointing to an old .out file.
Check your .out path and the date on that file to see how recent it might be.

Although the complete lack of reaction indicates to me that this may not be the case, check your DB37 cable. Have you properly fixed it as per the directions here?

How do you know that your PWM connections “reactly perfectly normally”?
Do lights on your Victors (or Jaguars) turn to a solid orange/yellow, or flash orange/yellow when you enable the robot? If not, what color do they indicate and when do they change?

My team has had the same problem. You may not be connected to your CRio or its not recognizing the code.

We switched each connection of our PWMs around and tested to see if they were communicating properly (which they are). I’m going to double check, but I believe the last time we tried enabling it it was solid orange/yellow (then flashed green and red rapidly like it should going forwards and backwards). What it seems like to me at the moment is somehow the cRIO is storing one of our old codes and for whatever reason is not replacing it with our new code (even though it gives us no errors when deploying).

If it is of any possible relation, ports 6-10 on our digital sidecar are not working period (but I think that’s a problem with our code possibly, I’m working with another of our programmers to look into the issue).