Our Rio is not communicating with our radio

Our radio is not communicating with our Rio, I can connect to the Rio via USB and it works fine but if i try to connect wirelessly via the radio, I can connect to the radio but I don’t receive any information from the RIO, I’ve tried resting the RIO and it worked once but I power cycled the robot to see if i can replicate the success and it is no longer working the it has went back to the same pattern of not connecting.

Wireless light- Green
Ethernet light - Flashing
Power - Solid

Rio Lights
Power- Green
Status- Amber during boot up then turns off
Comms- No light
RSL- Amber

If anything needs clarified please let me know, I haven’t been able to find any solutions to this problem.

Hmm. I seem to remember having this issue at an outreach event we recently had. If it’s the same issue we were having then rebooting the laptop should fix the issue.

First, try a wired Ethernet connection to the RIO, and see if you can ping it. If that works, connect wirelessly and see if you can ping it. If so, the problem is probably somewhere in a higher layer (i.e., the FRC software). If not, it’s probably a networking issue.

I’ll try that tomorrow and see if that works, but i have been working on solving this problem for a few days now but I’m not sure if the laptop has been rest.

I was able to ping it a believe though USB and I believe Ethernet (I can’t remember if I tried Ethernet but I think I did) via roboRIO-5944-FRC.local

Our team is 4 years old with only 5 people with 3 or more years of FRC experience so we don’t have any specialist when it comes to these types of thing.

If you can ping it with a direct Ethernet connection (you should definitely check that), you should try to hard-wire to the radio, then connect the radio to the rio like normal over ethernet. See whether or not that works.

Also, did you re-flash the radio after your last competition? If so, have you tried re-re-flashing it since the problem started?

What has changed since the last time you ran the robot?

(Is this the first time you’ve tried to run the robot since your last competition? I’ve had to re-flash radios “post competition” in the past.)

Screensteps link

Tone not necessary, re-flashing the radio is not obvious to me (as a mechE, coming up on 10 years in FRC)

Agreed, not obvious! We had to run tethered at a sponsor demo held two days after Beach Bot Battle because of this. With our robot and a fairly short cable, that was a serious limitation.

Competitions configure the radio so that it works in the limited environment of the competition field. This has to be undone before it can work in a different environment.

Obvious to a network engineer. Not so obvious to a mechanical engineer.

As a reply to everyone yes I’ve reset the radio, it was one of the first fixes I’ve tried, its notable that we did not have our robot running till competition, and it has not been working since competition. We also have had this issues in previous years most notable 2017 SteamPower. We have changed the Rio and Radio from year to year.

A green wireless light on the radio almost certainly means it’s still configured for your last competition, unless you somehow wound up with 2016 radio firmware on it (I don’t remember the light colors from 2016 off the top of my head). The wireless light should be orange when configured for home use. Make sure you have reflashed the firmware using the 2018 radio config utility (the one for home use), as well as configured the radio for your team number after flashing firmware.

Yeah it sounds like your radio was never properly configured for home use. You need to configure it at the beginning of every season, and then every time after you get home from a competition. You can find the instructions to do so here

UPDATE: The robot is now working the Radio Configure tool was out of date and I replaced some wires running to the radio. I was able to successfully power cycle four times and connect within a minute. Thank you everyone for the help.