PathPlanner 2023 Beta

We are able to get the FollowPathWithEvents working, but having problems with the Autobuilder. (10.1 KB)
Trying to implement the autobuilder in the RobotContainer class and getting a constructor not defined error.

Any help greatly appreciated.

SwerveAutoBuilder autoBuildsr2 = new SwerveAutoBuilder(
new PIDController(0.4, 0, 0),
new PIDController(0.2, 0, 0),

Popping back into this thread to say thank you to the OP. With this program, our students were able to adjust auton between matches for our first competition and eventually get events working so we could then autobalance.

Much appreciation!

BTW, we used the full auton builder instead of FollowWithEvents from my earlier post and that fixed up the issue.


You’re passing it PID controllers, it needs PIDConstants

1 Like

Is it possible to have a certain path of a json path group run slower than the others?
When there’s a 180 degrees holonomic rotation between 2 points I’d want to give it more time to rotate.

1 Like

Yes, the loadPathGroup method takes a vararg for PathConstraints. So, you can add as many as you want. If you add less than the number of segments in the group, the last one will be used for the rest of them.

1 Like

I’m back. Just want to thank you for this amazing tool that has helped us dramatically this season. We are just having one minor inconvenience but it would not need to be fixed. It seems that pathplanner crashes when you try to zoom in. Thank you again.


How are you trying to zoom in? Scroll wheel or trackpad gesture? Zooming still works fine for me on scroll wheel at least .

Trackpad. It does not crash until you try to click on something while zoomed in

How do I use a Ramsete Auto Builder for a differential drivetrain. There are 4 different ones and I dont know which one to use. Also whats the difference between using a PPRamseteController and RamseteAutoBuilder. It also throws an error when i try to reference the getWheelSpeedsFunction from my drivetrain subsystem.


Hello, I’ve been using PathPlanner for a long time to create auto paths. First, let me say its a great piece of software :smile:.

I just have one small question. Will an auto path work properly if we are on a different alliance and start on the other side of the field? Or, do we have to create two auto paths: one if we are on blue alliance and one if we are on red alliance?

Any suggestions for not being able run PP server? We are setting the port on RobotInit() and have set up 10.TE.AM.2 with the same port on PP app. We can’t get PP to connect to the robot. Have tested on different laptops with (I believe the same) MacOS.

How are you connecting to the robot? USB? Network cable? Wireless?

We were running it wireless. Should we try it tethered?

Nope just wondering if you were using the forbidden port.

Has this ever worked, did you add the line of code in the first line of robot init?

1 Like

There is a constructor that has a boolean parameter if you want to mirror the path. If you are going to mirror the path, make the path on the blue alliance in PathPlanner.

We tried putting it in the constructor of RobotContainer, didn’t work. Tried putting it in RobotInit right after initializing container. Well, I guess it wasn’t the first line. Would that make a difference though?

Just to be clear, did you do 10.TE.AM.2 or in the GUI? Dumb question but just making sure.

Beyond that, macOS can be kind of picky with local network access sometimes. The permissions should be configured for it but maybe try a windows laptop if you can.

1 Like

Yes, we were running Will try with a windows computer today thanks!

Yep, running it on Windows resolved it. Do you think it would be possible to get it working for MacOS? I opened an issue here. I am not sure if this is an actual bug or only something specific to my configuration. Let me know how to provide more information to diagnose the issue if it is actually broken.

Hello, i dont know if somebody has already asked this, but we are having some problems with the heading. While looking at the blue driver station, wpilib odometry reads 180 degrees, while in pathplanner we try to put it at that heading but the final path ends up being a bit strange.

So for now at least for us, using vision odometry in auto is not an option
Am i doing something wrong? Thanks